summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/strace/strace_4.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/strace/strace_4.8.bb')
-rw-r--r--meta/recipes-devtools/strace/strace_4.8.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-devtools/strace/strace_4.8.bb b/meta/recipes-devtools/strace/strace_4.8.bb
new file mode 100644
index 0000000000..c1ffdd1270
--- /dev/null
+++ b/meta/recipes-devtools/strace/strace_4.8.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "strace is a system call tracing tool."
2HOMEPAGE = "http://strace.sourceforge.net"
3SECTION = "console/utils"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=124500c21e856f0912df29295ba104c7"
6PR = "r0"
7
8SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.xz \
9 file://git-version-gen"
10
11SRC_URI[md5sum] = "c575ef43829586801f514fd91bfe7575"
12SRC_URI[sha256sum] = "f492291f07a7c805c07a8395cce1ea054a6401ad414f4cc12185672215e1d7f8"
13inherit autotools
14
15export INCLUDES = "-I. -I./linux"
16
17do_configure_prepend() {
18 cp ${WORKDIR}/git-version-gen ${S}
19}
20
21do_install_append() {
22 # We don't ship strace-graph here because it needs perl
23 rm ${D}${bindir}/strace-graph
24}
25
26BBCLASSEXTEND = "native"