summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rust/rust_1.57.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/rust/rust_1.57.0.bb')
-rw-r--r--meta/recipes-devtools/rust/rust_1.57.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rust/rust_1.57.0.bb b/meta/recipes-devtools/rust/rust_1.57.0.bb
new file mode 100644
index 0000000000..b505ad46ca
--- /dev/null
+++ b/meta/recipes-devtools/rust/rust_1.57.0.bb
@@ -0,0 +1,21 @@
1require rust-target.inc
2require rust-source.inc
3require rust-snapshot.inc
4
5INSANE_SKIP:${PN}:class-native = "already-stripped"
6
7do_compile () {
8 rust_runx build --stage 2
9}
10
11rust_do_install() {
12 rust_runx install
13}
14
15python () {
16 pn = d.getVar('PN')
17
18 if not pn.endswith("-native"):
19 raise bb.parse.SkipRecipe("Rust recipe doesn't work for target builds at this time. Fixes welcome.")
20}
21