summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rust/rust_1.51.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/rust/rust_1.51.0.bb')
-rw-r--r--meta/recipes-devtools/rust/rust_1.51.0.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rust/rust_1.51.0.bb b/meta/recipes-devtools/rust/rust_1.51.0.bb
new file mode 100644
index 0000000000..05904453f7
--- /dev/null
+++ b/meta/recipes-devtools/rust/rust_1.51.0.bb
@@ -0,0 +1,16 @@
1require rust-target.inc
2require rust-source-${PV}.inc
3require rust-snapshot-${PV}.inc
4
5SRC_URI += " \
6 file://riscv-march.patch \
7 file://rv64gc.patch \
8 "
9
10do_compile () {
11 rust_runx build --stage 2
12}
13
14rust_do_install() {
15 rust_runx install
16}