summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb')
-rw-r--r--meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb b/meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb
new file mode 100644
index 0000000000..5dd1709ff5
--- /dev/null
+++ b/meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb
@@ -0,0 +1,28 @@
1DESCRIPTION = "Run postinstall scripts on device"
2SECTION = "devel"
3PR = "r9"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
6 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
7
8SRC_URI = "file://run-postinsts"
9
10INITSCRIPT_NAME = "run-postinsts"
11INITSCRIPT_PARAMS = "start 98 S ."
12
13inherit update-rc.d
14
15do_configure() {
16 :
17}
18
19do_compile () {
20 :
21}
22
23do_install() {
24 install -d ${D}${sysconfdir}/init.d/
25 install -m 0755 ${WORKDIR}/run-postinsts ${D}${sysconfdir}/init.d/
26
27 sed -i -e 's:#SYSCONFDIR#:${sysconfdir}:g' ${D}${sysconfdir}/init.d/run-postinsts
28}