summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/ruby/ruby_2.4.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/ruby/ruby_2.4.1.bb')
-rw-r--r--meta/recipes-devtools/ruby/ruby_2.4.1.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-devtools/ruby/ruby_2.4.1.bb b/meta/recipes-devtools/ruby/ruby_2.4.1.bb
new file mode 100644
index 0000000000..1d335f1c28
--- /dev/null
+++ b/meta/recipes-devtools/ruby/ruby_2.4.1.bb
@@ -0,0 +1,44 @@
1require ruby.inc
2
3SRC_URI[md5sum] = "782bca562e474dd25956dd0017d92677"
4SRC_URI[sha256sum] = "a330e10d5cb5e53b3a0078326c5731888bb55e32c4abfeb27d9e7f8e5d000250"
5
6# it's unknown to configure script, but then passed to extconf.rb
7# maybe it's not really needed as we're hardcoding the result with
8# 0001-socket-extconf-hardcode-wide-getaddr-info-test-outco.patch
9UNKNOWN_CONFIGURE_WHITELIST += "--enable-wide-getaddrinfo"
10
11PACKAGECONFIG ??= ""
12PACKAGECONFIG += "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
13
14PACKAGECONFIG[valgrind] = "--with-valgrind=yes, --with-valgrind=no, valgrind"
15PACKAGECONFIG[gpm] = "--with-gmp=yes, --with-gmp=no, gmp"
16PACKAGECONFIG[ipv6] = ",--enable-wide-getaddrinfo,"
17
18EXTRA_AUTORECONF += "--exclude=aclocal"
19
20EXTRA_OECONF = "\
21 --disable-versioned-paths \
22 --disable-rpath \
23 --disable-dtrace \
24 --enable-shared \
25 --enable-load-relative \
26"
27
28do_install() {
29 oe_runmake 'DESTDIR=${D}' install
30}
31
32PACKAGES =+ "${PN}-ri-docs ${PN}-rdoc"
33
34SUMMARY_${PN}-ri-docs = "ri (Ruby Interactive) documentation for the Ruby standard library"
35RDEPENDS_${PN}-ri-docs = "${PN}"
36FILES_${PN}-ri-docs += "${datadir}/ri"
37
38SUMMARY_${PN}-rdoc = "RDoc documentation generator from Ruby source"
39RDEPENDS_${PN}-rdoc = "${PN}"
40FILES_${PN}-rdoc += "${libdir}/ruby/*/rdoc ${bindir}/rdoc"
41
42FILES_${PN} += "${datadir}/rubygems"
43
44BBCLASSEXTEND = "native"