summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rsync/rsync_3.3.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/rsync/rsync_3.3.0.bb')
-rw-r--r--meta/recipes-devtools/rsync/rsync_3.3.0.bb67
1 files changed, 67 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rsync/rsync_3.3.0.bb b/meta/recipes-devtools/rsync/rsync_3.3.0.bb
new file mode 100644
index 0000000000..a90d2887bd
--- /dev/null
+++ b/meta/recipes-devtools/rsync/rsync_3.3.0.bb
@@ -0,0 +1,67 @@
1SUMMARY = "File synchronization tool"
2HOMEPAGE = "http://rsync.samba.org/"
3DESCRIPTION = "rsync is an open source utility that provides fast incremental file transfer."
4BUGTRACKER = "http://rsync.samba.org/bugzilla.html"
5SECTION = "console/network"
6# GPL-2.0-or-later (<< 3.0.0), GPL-3.0-or-later (>= 3.0.0)
7# Includes opennsh and xxhash dynamic link exception
8LICENSE = "GPL-3.0-or-later"
9LIC_FILES_CHKSUM = "file://COPYING;md5=24423708fe159c9d12be1ea29fcb18c7"
10
11DEPENDS = "popt"
12
13SRC_URI = "https://download.samba.org/pub/${BPN}/src/${BP}.tar.gz \
14 file://rsyncd.conf \
15 file://makefile-no-rebuild.patch \
16 file://determism.patch \
17 file://0001-Add-missing-prototypes-to-function-declarations.patch \
18 "
19SRC_URI[sha256sum] = "7399e9a6708c32d678a72a63219e96f23be0be2336e50fd1348498d07041df90"
20
21inherit autotools-brokensep
22
23PACKAGECONFIG ??= "acl attr \
24 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
25"
26
27PACKAGECONFIG[acl] = "--enable-acl-support,--disable-acl-support,acl,"
28PACKAGECONFIG[attr] = "--enable-xattr-support,--disable-xattr-support,attr,"
29PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
30PACKAGECONFIG[lz4] = "--enable-lz4,--disable-lz4,lz4"
31PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
32PACKAGECONFIG[xxhash] = "--enable-xxhash,--disable-xxhash,xxhash"
33PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd"
34
35# By default, if crosscompiling, rsync disables a number of
36# capabilities, hardlinking symlinks and special files (i.e. devices)
37CACHED_CONFIGUREVARS += "rsync_cv_can_hardlink_special=yes rsync_cv_can_hardlink_symlink=yes"
38
39EXTRA_OEMAKE = 'STRIP=""'
40EXTRA_OECONF = "--disable-md2man --with-nobody-group=nogroup"
41
42#| ./simd-checksum-x86_64.cpp: In function 'uint32_t get_checksum1_cpp(char*, int32_t)':
43#| ./simd-checksum-x86_64.cpp:89:52: error: multiversioning needs 'ifunc' which is not supported on this target
44#| 89 | __attribute__ ((target("default"))) MVSTATIC int32 get_checksum1_avx2_64(schar* buf, int32 len, int32 i, uint32* ps1, uint32* ps2) { return i; }
45#| | ^~~~~~~~~~~~~~~~~~~~~
46#| ./simd-checksum-x86_64.cpp:480:1: error: use of multiversioned function without a default
47#| 480 | }
48#| | ^
49#| If you can't fix the issue, re-run ./configure with --disable-roll-simd.
50EXTRA_OECONF:append:libc-musl = " --disable-roll-simd"
51
52# rsync 3.0 uses configure.sh instead of configure, and
53# makefile checks the existence of configure.sh
54do_configure:prepend () {
55 rm -f ${S}/configure ${S}/configure.sh
56}
57
58do_configure:append () {
59 cp -f ${S}/configure ${S}/configure.sh
60}
61
62do_install:append() {
63 install -d ${D}${sysconfdir}
64 install -m 0644 ${UNPACKDIR}/rsyncd.conf ${D}${sysconfdir}
65}
66
67BBCLASSEXTEND = "native nativesdk"