summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rsync/rsync_3.2.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/rsync/rsync_3.2.5.bb')
-rw-r--r--meta/recipes-devtools/rsync/rsync_3.2.5.bb69
1 files changed, 69 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rsync/rsync_3.2.5.bb b/meta/recipes-devtools/rsync/rsync_3.2.5.bb
new file mode 100644
index 0000000000..a1ba5ea44d
--- /dev/null
+++ b/meta/recipes-devtools/rsync/rsync_3.2.5.bb
@@ -0,0 +1,69 @@
1SUMMARY = "File synchronization tool"
2HOMEPAGE = "http://rsync.samba.org/"
3DESCRIPTION = "rsync is an open source utility that provides fast incremental file transfer."
4BUGTRACKER = "http://rsync.samba.org/bugzilla.html"
5SECTION = "console/network"
6# GPL-2.0-or-later (<< 3.0.0), GPL-3.0-or-later (>= 3.0.0)
7# Includes opennsh and xxhash dynamic link exception
8LICENSE = "GPL-3.0-or-later"
9LIC_FILES_CHKSUM = "file://COPYING;md5=24423708fe159c9d12be1ea29fcb18c7"
10
11DEPENDS = "popt"
12
13SRC_URI = "https://download.samba.org/pub/${BPN}/src/${BP}.tar.gz \
14 file://rsyncd.conf \
15 file://makefile-no-rebuild.patch \
16 file://determism.patch \
17 "
18SRC_URI[sha256sum] = "2ac4d21635cdf791867bc377c35ca6dda7f50d919a58be45057fd51600c69aba"
19
20# -16548 required for v3.1.3pre1. Already in v3.1.3.
21CVE_CHECK_IGNORE += " CVE-2017-16548 "
22
23inherit autotools-brokensep
24
25PACKAGECONFIG ??= "acl attr \
26 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
27"
28
29PACKAGECONFIG[acl] = "--enable-acl-support,--disable-acl-support,acl,"
30PACKAGECONFIG[attr] = "--enable-xattr-support,--disable-xattr-support,attr,"
31PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
32PACKAGECONFIG[lz4] = "--enable-lz4,--disable-lz4,lz4"
33PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
34PACKAGECONFIG[xxhash] = "--enable-xxhash,--disable-xxhash,xxhash"
35PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd"
36
37# By default, if crosscompiling, rsync disables a number of
38# capabilities, hardlinking symlinks and special files (i.e. devices)
39CACHED_CONFIGUREVARS += "rsync_cv_can_hardlink_special=yes rsync_cv_can_hardlink_symlink=yes"
40
41EXTRA_OEMAKE = 'STRIP=""'
42EXTRA_OECONF = "--disable-md2man --with-nobody-group=nogroup"
43
44#| ./simd-checksum-x86_64.cpp: In function 'uint32_t get_checksum1_cpp(char*, int32_t)':
45#| ./simd-checksum-x86_64.cpp:89:52: error: multiversioning needs 'ifunc' which is not supported on this target
46#| 89 | __attribute__ ((target("default"))) MVSTATIC int32 get_checksum1_avx2_64(schar* buf, int32 len, int32 i, uint32* ps1, uint32* ps2) { return i; }
47#| | ^~~~~~~~~~~~~~~~~~~~~
48#| ./simd-checksum-x86_64.cpp:480:1: error: use of multiversioned function without a default
49#| 480 | }
50#| | ^
51#| If you can't fix the issue, re-run ./configure with --disable-roll-simd.
52EXTRA_OECONF:append:libc-musl = " --disable-roll-simd"
53
54# rsync 3.0 uses configure.sh instead of configure, and
55# makefile checks the existence of configure.sh
56do_configure:prepend () {
57 rm -f ${S}/configure ${S}/configure.sh
58}
59
60do_configure:append () {
61 cp -f ${S}/configure ${S}/configure.sh
62}
63
64do_install:append() {
65 install -d ${D}${sysconfdir}
66 install -m 0644 ${WORKDIR}/rsyncd.conf ${D}${sysconfdir}
67}
68
69BBCLASSEXTEND = "native nativesdk"