summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm/rpm_5.4.16.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/rpm/rpm_5.4.16.bb')
-rw-r--r--meta/recipes-devtools/rpm/rpm_5.4.16.bb18
1 files changed, 9 insertions, 9 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_5.4.16.bb b/meta/recipes-devtools/rpm/rpm_5.4.16.bb
index d264d5011a..84adef661a 100644
--- a/meta/recipes-devtools/rpm/rpm_5.4.16.bb
+++ b/meta/recipes-devtools/rpm/rpm_5.4.16.bb
@@ -259,7 +259,7 @@ PACKAGECONFIG[xar] = "--with-xar,--without-xar,xar,"
259 259
260WITH_PYTHON = " --with-python=${PYTHON_BASEVERSION} \ 260WITH_PYTHON = " --with-python=${PYTHON_BASEVERSION} \
261 --with-python-inc-dir=${STAGING_INCDIR}/python${PYTHON_BASEVERSION} \ 261 --with-python-inc-dir=${STAGING_INCDIR}/python${PYTHON_BASEVERSION} \
262 --with-python-lib-dir=${libdir}/python${PYTHON_BASEVERSION}/site-packages \ 262 --with-python-lib-dir=${PYTHON_SITEPACKAGES_DIR} \
263 --without-pythonembed" 263 --without-pythonembed"
264PACKAGECONFIG[python] = "${WITH_PYTHON},--without-python,python," 264PACKAGECONFIG[python] = "${WITH_PYTHON},--without-python,python,"
265 265
@@ -477,7 +477,7 @@ RDEPENDS_${PN}-build = "file bash perl"
477 477
478RDEPENDS_python-rpm = "${PN} python" 478RDEPENDS_python-rpm = "${PN} python"
479 479
480FILES_python-rpm = "${libdir}/python*/site-packages/rpm" 480FILES_python-rpm = "${PYTHON_SITEPACKAGES_DIR}/rpm"
481PROVIDES += "python-rpm" 481PROVIDES += "python-rpm"
482 482
483FILES_perl-module-rpm = "${libdir}/perl/*/* \ 483FILES_perl-module-rpm = "${libdir}/perl/*/* \
@@ -512,7 +512,7 @@ FILES_${PN}-staticdev = " \
512 ${libdir}/librpmmisc.a \ 512 ${libdir}/librpmmisc.a \
513 ${libdir}/librpmbuild.a \ 513 ${libdir}/librpmbuild.a \
514 ${libdir}/rpm/lib/liblua.a \ 514 ${libdir}/rpm/lib/liblua.a \
515 ${libdir}/python*/site-packages/rpm/*.a \ 515 ${PYTHON_SITEPACKAGES_DIR}/rpm/*.a \
516 " 516 "
517 517
518do_configure() { 518do_configure() {
@@ -581,10 +581,10 @@ do_install_append() {
581 rm -f ${D}/${mandir}/man1/lz*.1 581 rm -f ${D}/${mandir}/man1/lz*.1
582 rm -f ${D}/${libdir}/pkgconfig/liblzma* 582 rm -f ${D}/${libdir}/pkgconfig/liblzma*
583 583
584 rm -f ${D}/${libdir}/python%{with_python_version}/site-packages/*.a 584 rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/*.a
585 rm -f ${D}/${libdir}/python%{with_python_version}/site-packages/*.la 585 rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/*.la
586 rm -f ${D}/${libdir}/python%{with_python_version}/site-packages/rpm/*.a 586 rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/rpm/*.a
587 rm -f ${D}/${libdir}/python%{with_python_version}/site-packages/rpm/*.la 587 rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/rpm/*.la
588 588
589 #find ${D}/${libdir}/perl5 -type f -a \( -name perllocal.pod -o -name .packlist \ 589 #find ${D}/${libdir}/perl5 -type f -a \( -name perllocal.pod -o -name .packlist \
590 # -o \( -name '*.bs' -a -empty \) \) -exec rm -f {} ';' 590 # -o \( -name '*.bs' -a -empty \) \) -exec rm -f {} ';'
@@ -647,11 +647,11 @@ EOF
647} 647}
648 648
649do_install_append_class-native () { 649do_install_append_class-native () {
650 sed -i -e 's|^#!.*/usr/bin/python|#! /usr/bin/env nativepython|' ${D}/${libdir}/python2.7/site-packages/rpm/transaction.py 650 sed -i -e 's|^#!.*/usr/bin/python|#! /usr/bin/env nativepython|' ${D}${PYTHON_SITEPACKAGES_DIR}/rpm/transaction.py
651} 651}
652 652
653do_install_append_class-nativesdk () { 653do_install_append_class-nativesdk () {
654 sed -i -e 's|^#!.*/usr/bin/python|#! /usr/bin/env python|' ${D}/${libdir}/python2.7/site-packages/rpm/transaction.py 654 sed -i -e 's|^#!.*/usr/bin/python|#! /usr/bin/env python|' ${D}${PYTHON_SITEPACKAGES_DIR}/rpm/transaction.py
655} 655}
656 656
657def multilib_rpmmacros(d): 657def multilib_rpmmacros(d):