summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm/rpm_5.4.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/rpm/rpm_5.4.14.bb')
-rw-r--r--meta/recipes-devtools/rpm/rpm_5.4.14.bb518
1 files changed, 518 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_5.4.14.bb b/meta/recipes-devtools/rpm/rpm_5.4.14.bb
new file mode 100644
index 0000000000..d99a300285
--- /dev/null
+++ b/meta/recipes-devtools/rpm/rpm_5.4.14.bb
@@ -0,0 +1,518 @@
1SUMMARY = "The RPM package management system"
2DESCRIPTION = "The RPM Package Manager (RPM) is a powerful command line driven \
3package management system capable of installing, uninstalling, \
4verifying, querying, and updating software packages. Each software \
5package consists of an archive of files along with information about \
6the package like its version, a description, etc."
7
8SUMMARY_${PN}-libs = "Libraries for manipulating RPM packages"
9DESCRIPTION_${PN}-libs = "This package contains the RPM shared libraries."
10
11SUMMARY_${PN}-dev = "Development files for manipulating RPM packages"
12DESCRIPTION_${PN}-dev = "This package contains the RPM C library and header files. These \
13development files will simplify the process of writing programs that \
14manipulate RPM packages and databases. These files are intended to \
15simplify the process of creating graphical package managers or any \
16other tools that need an intimate knowledge of RPM packages in order \
17to function."
18
19SUMMARY_${PN}-common = "Common RPM paths, scripts, documentation and configuration"
20DESCRIPTION_${PN}-common = "The rpm-common package contains paths, scripts, documentation \
21and configuration common between RPM Package Manager."
22
23SUMMARY_${PN}-build = "Scripts and executable programs used to build packages"
24DESCRIPTION_${PN}-build = "The rpm-build packagec ontains the scripts and executable programs \
25that are used to build packages using the RPM Package Manager."
26
27SUMMARY_python-rpm = "Python bindings for apps which will manupulate RPM packages"
28DESCRIPTION_python-rpm = "The rpm-python package contains a module that permits applications \
29written in the Python programming language to use the interface \
30supplied by the RPM Package Manager libraries."
31
32SUMMARY_perl-module-rpm = "Perl bindings for apps which will manipulate RPM packages"
33DESCRIPTION_perl-modules-rpm = "The perl-modules-rpm package contains a module that permits applications \
34written in the Perl programming language to use the interface \
35supplied by the RPM Package Manager libraries."
36
37SUMMARY_perl-module-rpm-dev = "Development components for perl bindings"
38DESCRIPTION_perl-modules-rpm-dev = "Development items such as man pages for use with the Perl \
39language bindings."
40
41HOMEPAGE = "http://rpm5.org/"
42LICENSE = "LGPLv2.1"
43LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1"
44
45DEPENDS = "libpcre attr acl popt ossp-uuid file byacc-native"
46
47# rpm2cpio is a shell script, which is part of the rpm src.rpm. It is needed
48# in order to extract the distribution SRPM into a format we can extract...
49SRC_URI = "http://www.rpm5.org/files/rpm/rpm-5.4/rpm-5.4.14-0.20131024.src.rpm;extract=rpm-5.4.14.tar.gz \
50 file://rpm-log-auto-rm.patch \
51 file://rpm-db-reduce.patch \
52 file://perfile_rpmdeps.sh \
53 file://rpm-autogen.patch \
54 file://rpm-libsql-fix.patch \
55 file://header-include-fix.patch \
56 file://rpm-platform.patch \
57 file://rpm-showrc.patch \
58 file://rpm-tools-mtree-LDFLAGS.patch \
59 file://rpm-fileclass.patch \
60 file://rpm-canonarch.patch \
61 file://rpm-no-loopmsg.patch \
62 file://rpm-scriptletexechelper.patch \
63 file://pythondeps.sh \
64 file://rpmdeps-oecore.patch \
65 file://rpm-resolvedep.patch \
66 file://rpm-no-perl-urpm.patch \
67 file://rpm-macros.patch \
68 file://rpm-lua.patch \
69 file://rpm-ossp-uuid.patch \
70 file://rpm-packageorigin.patch \
71 file://rpm-pkgconfigdeps.patch \
72 file://uclibc-support.patch \
73 file://rpmatch.patch \
74 file://fstack-protector-configure-check.patch \
75 file://dbconvert.patch \
76 file://rpm-uuid-include.patch \
77 file://makefile-am-exec-hook.patch \
78 file://rpm-db_buffer_small.patch \
79 file://rpm-py-init.patch \
80 file://python-rpm-rpmsense.patch \
81 file://rpm-reloc-macros.patch \
82 file://rpm-platform2.patch \
83 file://rpm-remove-sykcparse-decl.patch \
84 file://debugedit-segv.patch \
85 file://debugedit-valid-file-to-fix-segment-fault.patch \
86 file://rpm-platform-file-fix.patch \
87 file://rpm-lsb-compatibility.patch \
88 file://rpm-tag-generate-endian-conversion-fix.patch \
89 file://verify-fix-broken-logic-for-ghost-avoidance-Mark-Hat.patch \
90 file://rpm-hardlink-segfault-fix.patch \
91 file://rpm-payload-use-hashed-inode.patch \
92 file://rpm-fix-logio-cp.patch \
93 file://rpm-db5-or-db6.patch \
94 file://rpm-disable-Wno-override-init.patch \
95 file://rpmqv_cc_b_gone.patch \
96 file://rpm-realpath.patch \
97 file://0001-using-poptParseArgvString-to-parse-the-_gpg_check_pa.patch \
98 "
99
100# Uncomment the following line to enable platform score debugging
101# This is useful when identifying issues with Smart being unable
102# to process certain package feeds.
103#SRC_URI += "file://rpm-debug-platform.patch"
104
105SRC_URI[md5sum] = "25093d399a0b5d1342d24900a91b347d"
106SRC_URI[sha256sum] = "676e3ab41f72e3b504e04109cfb565a300742f56a7da084f202013b30eeae467"
107
108inherit autotools gettext
109
110acpaths = "-I ${S}/db/dist/aclocal -I ${S}/db/dist/aclocal_java"
111
112# Specify the default rpm macros in terms of adjustable variables
113rpm_macros = "%{_usrlibrpm}/macros:%{_usrlibrpm}/poky/macros:%{_usrlibrpm}/poky/%{_target}/macros:%{_etcrpm}/macros.*:%{_etcrpm}/macros:%{_etcrpm}/%{_target}/macros:~/.oerpmmacros"
114rpm_macros_class-native = "%{_usrlibrpm}/macros:%{_usrlibrpm}/poky/macros:%{_usrlibrpm}/poky/%{_target}/macros:~/.oerpmmacros"
115rpm_macros_class-nativesdk = "%{_usrlibrpm}/macros:%{_usrlibrpm}/poky/macros:%{_usrlibrpm}/poky/%{_target}/macros:~/.oerpmmacros"
116
117# sqlite lua tcl augeas nss gcrypt neon xz xar keyutils perl selinux
118
119# Note: perl and sqlite w/o db specified does not currently work.
120# tcl, augeas, nss, gcrypt, xar and keyutils support is untested.
121PACKAGECONFIG ??= "db bzip2 zlib beecrypt openssl libelf python"
122
123PACKAGECONFIG[bzip2] = "--with-bzip2,--without-bzip2,bzip2,"
124PACKAGECONFIG[xz] = "--with-xz,--without-xz,xz,"
125PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib,"
126PACKAGECONFIG[xar] = "--with-xar,--without-xar,xar,"
127
128WITH_PYTHON = " --with-python=${PYTHON_BASEVERSION} \
129 --with-python-inc-dir=${STAGING_INCDIR}/python${PYTHON_BASEVERSION} \
130 --with-python-lib-dir=${libdir}/python${PYTHON_BASEVERSION}/site-packages \
131 --without-pythonembed"
132PACKAGECONFIG[python] = "${WITH_PYTHON},--without-python,python,"
133
134# Perl modules are not built, but they could be enabled fairly easily
135# the perl module creation and installation would need to be patched.
136# (currently has host perl contamination issues)
137WITH_PERL = "--with-perl --without-perlembed --without-perl-urpm"
138WITHOUT_PERL = "--without-perl --without-perl-urpm"
139PACKAGECONFIG[perl] = "${WITH_PERL},${WITHOUT_PERL},perl,"
140
141# The --with-dbsql will only tell RPM to check for support, db
142# may or may not be built w/ the dbsql support.
143WITH_DB = "--with-db --with-dbsql --without-db-tools-integrated"
144PACKAGECONFIG[db] = "${WITH_DB},--without-db,db,"
145
146PACKAGECONFIG[sqlite] = "--with-sqlite,--without-sqlite,sqlite3,"
147
148PACKAGECONFIG[beecrypt] = "--with-beecrypt=external,--without-beecrypt,beecrypt,"
149PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl,"
150PACKAGECONFIG[nss] = "--with-nss,--without-nss,nss,"
151PACKAGECONFIG[gcrypt] = "--with-gcrypt,--without-gcrypt,gcrypt,"
152PACKAGECONFIG[keyutils] = "--with-keyutils,--without-keyutils,keyutils,"
153PACKAGECONFIG[libelf] = "--with-libelf,--without-libelf,elfutils,"
154
155WITH_SELINUX = "--with-selinux --with-sepol --with-semanage"
156WITHOUT_SELINUX = "--without-selinux --without-sepol --without-semanage"
157PACKAGECONFIG[selinux] = "${WITH_SELINUX},${WITHOUT_SELINUX},libselinux,"
158
159WITH_NEON = "--with-neon --with-libproxy --with-expat --without-gssapi"
160WITHOUT_NEON = "--without-neon --without-libproxy --without-expat --without-gssapi"
161PACKAGECONFIG[neon] = "${WITH_NEON},${WITHOUT_NEON},neon expat,"
162
163PACKAGECONFIG[lua] = "--with-lua,--without-lua,expat,"
164PACKAGECONFIG[tcl] = "--with-tcl,--without-tcl,tcl,"
165
166PACKAGECONFIG[augeas] = "--with-augeas,--without-augeas,augeas,"
167
168EXTRA_OECONF += "--verbose \
169 --sysconfdir=${sysconfdir} \
170 --with-file \
171 --with-path-magic=%{_usrlibrpm}/../../share/misc/magic.mgc \
172 --with-syck=internal \
173 --without-readline \
174 --without-libtasn1 \
175 --without-pakchois \
176 --without-gnutls \
177 --with-pcre \
178 --enable-utf8 \
179 --with-uuid \
180 --with-attr \
181 --with-acl \
182 --with-popt=external \
183 --with-pthreads \
184 --without-cudf \
185 --without-ficl \
186 --without-aterm \
187 --without-nix \
188 --without-bash \
189 --without-rc \
190 --without-js \
191 --without-gpsee \
192 --without-ruby \
193 --without-squirrel \
194 --with-build-extlibdep \
195 --with-build-maxextlibdep \
196 --without-valgrind \
197 --disable-openmp \
198 --enable-build-pic \
199 --enable-build-versionscript \
200 --enable-build-warnings \
201 --enable-build-debug \
202 --enable-maintainer-mode \
203 --with-path-macros=${rpm_macros} \
204 --with-path-lib=${libdir}/rpm \
205 --with-bugreport=http://bugzilla.yoctoproject.org \
206 --program-prefix= \
207 YACC=byacc"
208
209CFLAGS_append = " -DRPM_VENDOR_WINDRIVER -DRPM_VENDOR_POKY -DRPM_VENDOR_OE"
210
211LDFLAGS_append_libc-uclibc = "-lrt -lpthread"
212
213PACKAGES = "${PN}-dbg ${PN} ${PN}-doc ${PN}-libs ${PN}-dev ${PN}-staticdev ${PN}-common ${PN}-build python-rpm-dbg python-rpm-staticdev python-rpm-dev python-rpm perl-module-rpm perl-module-rpm-dev ${PN}-locale"
214
215SOLIBS = "5.4.so"
216
217# Based on %files section in the rpm.spec
218
219FILES_${PN} = "${bindir}/rpm \
220 ${bindir}/rpmconstant \
221 ${libdir}/rpm/rpm.* \
222 ${libdir}/rpm/tgpg \
223 ${libdir}/rpm/macros \
224 ${libdir}/rpm/rpmpopt \
225 ${libdir}/rpm/rpm2cpio \
226 ${libdir}/rpm/vcheck \
227 ${libdir}/rpm/helpers \
228 ${libdir}/rpm/qf \
229 ${libdir}/rpm/cpuinfo.yaml \
230 ${libdir}/rpm/bin/mtree \
231 ${libdir}/rpm/bin/rpmkey \
232 ${libdir}/rpm/bin/rpmrepo \
233 ${libdir}/rpm/bin/rpmrepo.real \
234 ${libdir}/rpm/bin/rpmspecdump \
235 ${libdir}/rpm/bin/rpmspecdump.real \
236 ${libdir}/rpm/bin/wget \
237 ${localstatedir}/cache \
238 ${localstatedir}/cache/rpm \
239 ${localstatedir}/cache/wdj \
240 ${localstatedir}/lib \
241 ${localstatedir}/lib/rpm \
242 ${localstatedir}/lib/wdj \
243 ${bindir}/rpm.real \
244 ${bindir}/rpmconstant.real \
245 ${bindir}/rpm2cpio.real \
246 "
247
248FILES_${PN}-dbg += "${libdir}/rpm/.debug \
249 ${libdir}/rpm/bin/.debug \
250 "
251
252FILES_${PN}-common = "${bindir}/rpm2cpio \
253 ${bindir}/gendiff \
254 ${sysconfdir}/rpm \
255 ${localstatedir}/spool/repackage \
256 "
257
258FILES_${PN}-libs = "${libdir}/librpm-*.so \
259 ${libdir}/librpmconstant-*.so \
260 ${libdir}/librpmdb-*.so \
261 ${libdir}/librpmio-*.so \
262 ${libdir}/librpmmisc-*.so \
263 ${libdir}/librpmbuild-*.so \
264 "
265
266FILES_${PN}-build = "${prefix}/src/rpm \
267 ${bindir}/rpmbuild \
268 ${bindir}/rpmbuild.real \
269 ${libdir}/rpm/brp-* \
270 ${libdir}/rpm/check-files \
271 ${libdir}/rpm/cross-build \
272 ${libdir}/rpm/find-debuginfo.sh \
273 ${libdir}/rpm/find-lang.sh \
274 ${libdir}/rpm/find-prov.pl \
275 ${libdir}/rpm/find-provides.perl \
276 ${libdir}/rpm/find-req.pl \
277 ${libdir}/rpm/find-requires.perl \
278 ${libdir}/rpm/getpo.sh \
279 ${libdir}/rpm/http.req \
280 ${libdir}/rpm/javadeps.sh \
281 ${libdir}/rpm/mono-find-provides \
282 ${libdir}/rpm/mono-find-requires \
283 ${libdir}/rpm/executabledeps.sh \
284 ${libdir}/rpm/libtooldeps.sh \
285 ${libdir}/rpm/osgideps.pl \
286 ${libdir}/rpm/perldeps.pl \
287 ${libdir}/rpm/perl.prov \
288 ${libdir}/rpm/perl.req \
289 ${libdir}/rpm/php.prov \
290 ${libdir}/rpm/php.req \
291 ${libdir}/rpm/pkgconfigdeps.sh \
292 ${libdir}/rpm/pythondeps.sh \
293 ${libdir}/rpm/bin/debugedit \
294 ${libdir}/rpm/bin/debugedit.real \
295 ${libdir}/rpm/bin/rpmcache \
296 ${libdir}/rpm/bin/rpmcache.real \
297 ${libdir}/rpm/bin/rpmcmp \
298 ${libdir}/rpm/bin/rpmcmp.real \
299 ${libdir}/rpm/bin/rpmdeps \
300 ${libdir}/rpm/bin/rpmdeps.real \
301 ${libdir}/rpm/bin/rpmdeps-oecore \
302 ${libdir}/rpm/bin/rpmdeps-oecore.real \
303 ${libdir}/rpm/bin/rpmdigest \
304 ${libdir}/rpm/bin/rpmdigest.real \
305 ${libdir}/rpm/bin/abi-compliance-checker.pl \
306 ${libdir}/rpm/bin/api-sanity-autotest.pl \
307 ${libdir}/rpm/bin/chroot \
308 ${libdir}/rpm/bin/cp \
309 ${libdir}/rpm/bin/dbsql \
310 ${libdir}/rpm/bin/find \
311 ${libdir}/rpm/bin/install-sh \
312 ${libdir}/rpm/bin/lua \
313 ${libdir}/rpm/bin/luac \
314 ${libdir}/rpm/bin/mkinstalldirs \
315 ${libdir}/rpm/bin/rpmlua \
316 ${libdir}/rpm/bin/rpmluac \
317 ${libdir}/rpm/bin/sqlite3 \
318 ${libdir}/rpm/macros.d/cmake \
319 ${libdir}/rpm/macros.d/java \
320 ${libdir}/rpm/macros.d/libtool \
321 ${libdir}/rpm/macros.d/mandriva \
322 ${libdir}/rpm/macros.d/mono \
323 ${libdir}/rpm/macros.d/perl \
324 ${libdir}/rpm/macros.d/php \
325 ${libdir}/rpm/macros.d/pkgconfig \
326 ${libdir}/rpm/macros.d/python \
327 ${libdir}/rpm/macros.d/ruby \
328 ${libdir}/rpm/macros.d/selinux \
329 ${libdir}/rpm/macros.d/tcl \
330 ${libdir}/rpm/macros.rpmbuild \
331 ${libdir}/rpm/u_pkg.sh \
332 ${libdir}/rpm/vpkg-provides.sh \
333 ${libdir}/rpm/vpkg-provides2.sh \
334 ${libdir}/rpm/perfile_rpmdeps.sh \
335 "
336RDEPENDS_${PN} = "base-files run-postinsts"
337RDEPENDS_${PN}_class-native = ""
338RDEPENDS_${PN}_class-nativesdk = ""
339RDEPENDS_${PN}-build = "file bash perl"
340
341RDEPENDS_python-rpm = "${PN}"
342
343FILES_python-rpm-dbg = "${libdir}/python*/site-packages/rpm/.debug/_*"
344FILES_python-rpm-dev = "${libdir}/python*/site-packages/rpm/*.la"
345FILES_python-rpm-staticdev = "${libdir}/python*/site-packages/rpm/*.a"
346FILES_python-rpm = "${libdir}/python*/site-packages/rpm"
347PROVIDES += "python-rpm"
348
349FILES_perl-module-rpm = "${libdir}/perl/*/* \
350 "
351
352FILES_perl-module-rpm-dev = "${prefix}/share/man/man3/RPM* \
353 "
354
355RDEPENDS_${PN}-dev += "bash"
356
357FILES_${PN}-dev = "${includedir}/rpm \
358 ${libdir}/librpm.la \
359 ${libdir}/librpm.so \
360 ${libdir}/librpmconstant.la \
361 ${libdir}/librpmconstant.so \
362 ${libdir}/librpmdb.la \
363 ${libdir}/librpmdb.so \
364 ${libdir}/librpmio.la \
365 ${libdir}/librpmio.so \
366 ${libdir}/librpmmisc.la \
367 ${libdir}/librpmmisc.so \
368 ${libdir}/librpmbuild.la \
369 ${libdir}/librpmbuild.so \
370 ${libdir}/rpm/lib/liblua.la \
371 ${libdir}/pkgconfig/rpm.pc \
372 ${libdir}/rpm/rpmdb_loadcvt \
373 "
374
375FILES_${PN}-staticdev = " \
376 ${libdir}/librpm.a \
377 ${libdir}/librpmconstant.a \
378 ${libdir}/librpmdb.a \
379 ${libdir}/librpmio.a \
380 ${libdir}/librpmmisc.a \
381 ${libdir}/librpmbuild.a \
382 ${libdir}/rpm/lib/liblua.a \
383 "
384
385do_configure() {
386 # Disable tests!
387 echo "all:" > ${S}/tests/Makefile.am
388 sed -e 's/@__MKDIR_P@/%{__mkdir} -p/' -i ${S}/macros/macros.in
389
390 ( cd ${S}; ${S}/autogen.sh )
391
392 # NASTY hack to make sure configure files the right pkg-config file...
393 sed -e 's/pkg-config --exists uuid/pkg-config --exists ossp-uuid/g' \
394 -e 's/pkg-config uuid/pkg-config ossp-uuid/g' -i ${S}/configure
395
396 ( cd ${S}/syck ; set +e ; rm -- -l* ; make distclean ) || :
397
398 export varprefix=${localstatedir}
399 oe_runconf
400}
401
402do_install_append() {
403 sed -i -e 's,%__check_files,#%%__check_files,' ${D}/${libdir}/rpm/macros
404 sed -i -e 's,%__scriptlet_requires,#%%__scriptlet_requires,' ${D}/${libdir}/rpm/macros
405 sed -i -e 's,%__perl_provides,#%%__perl_provides,' ${D}/${libdir}/rpm/macros ${D}/${libdir}/rpm/macros.d/*
406 sed -i -e 's,%__perl_requires,#%%__perl_requires,' ${D}/${libdir}/rpm/macros ${D}/${libdir}/rpm/macros.d/*
407 sed -i -e 's,%_repackage_all_erasures[^_].*,%_repackage_all_erasures 0,' ${D}/${libdir}/rpm/macros
408 sed -i -e 's,^#%_openall_before_chroot.*,%_openall_before_chroot\t1,' ${D}/${libdir}/rpm/macros
409
410 # Enable Debian style arbitrary tags...
411 sed -i -e 's,%_arbitrary_tags[^_].*,%_arbitrary_tags %{_arbitrary_tags_debian},' ${D}/${libdir}/rpm/macros
412
413 install -m 0755 ${WORKDIR}/pythondeps.sh ${D}/${libdir}/rpm/pythondeps.sh
414 install -m 0755 ${WORKDIR}/perfile_rpmdeps.sh ${D}/${libdir}/rpm/perfile_rpmdeps.sh
415
416 # Remove unpackaged files (based on list in rpm.spec)
417 rm -f ${D}/${libdir}/rpm/{Specfile.pm,cpanflute,cpanflute2,rpmdiff,rpmdiff.cgi,sql.prov,sql.req,tcl.req,trpm}
418
419 rm -f ${D}/${mandir}/man8/rpmcache.8*
420 rm -f ${D}/${mandir}/man8/rpmgraph.8*
421 rm -f ${D}/${mandir}/*/man8/rpmcache.8*
422 rm -f ${D}/${mandir}/*/man8/rpmgraph.8*
423 rm -rf ${D}/${mandir}/{fr,ko}
424
425 rm -f ${D}/${includedir}/popt.h
426 rm -f ${D}/${libdir}/libpopt.*
427 rm -f ${D}/${libdir}/pkgconfig/popt.pc
428 rm -f ${D}/${datadir}/locale/*/LC_MESSAGES/popt.mo
429 rm -f ${D}/${mandir}/man3/popt.3
430
431 rm -f ${D}/${mandir}/man1/xar.1*
432 rm -f ${D}/${bindir}/xar
433 rm -rf ${D}/${includedir}/xar
434 rm -f ${D}/${libdir}/libxar*
435
436 rm -f ${D}/${bindir}/lz*
437 rm -f ${D}/${bindir}/unlzma
438 rm -f ${D}/${bindir}/unxz
439 rm -f ${D}/${bindir}/xz*
440 rm -rf ${D}/${includedir}/lzma*
441 rm -f ${D}/${mandir}/man1/lz*.1
442 rm -f ${D}/${libdir}/pkgconfig/liblzma*
443
444 rm -f ${D}/${libdir}/python%{with_python_version}/site-packages/*.{a,la}
445 rm -f ${D}/${libdir}/python%{with_python_version}/site-packages/rpm/*.{a,la}
446
447 #find ${D}/${libdir}/perl5 -type f -a \( -name perllocal.pod -o -name .packlist \
448 # -o \( -name '*.bs' -a -empty \) \) -exec rm -f {} ';'
449 #find ${D}/${libdir}/perl5 -type d -depth -exec rmdir {} 2>/dev/null ';'
450
451 # We don't want the default macro set
452 rm -rf ${D}/${libdir}/rpm/{i[3456]86*,athlon*,pentium*,x86_64*,alpha*,sparc*,ia64*,ppc*,s390*,armv[34][lb]*,armv[345]*,mips*,noarch*}
453
454 rm -f ${D}/${libdir}/rpm/dbconvert.sh
455
456 rm -f ${D}/${libdir}/rpm/libsqldb.*
457
458 # We don't want, nor need the Mandriva multiarch items
459 rm -f ${D}/${bindir}/multiarch-dispatch
460 rm -f ${D}/${bindir}/multiarch-platform
461 rm -f ${D}/${libdir}/rpm/check-multiarch-files
462 rm -f ${D}/${libdir}/rpm/mkmultiarch
463 rm -f ${D}/${includedir}/multiarch-dispatch.h
464
465 rm -f ${D}/${libdir}/rpm/gstreamer.sh
466 rm -f ${D}/${libdir}/rpm/gem_helper.rb
467 rm -f ${D}/${libdir}/rpm/rubygems.rb
468 rm -f ${D}/${libdir}/rpm/kmod-deps.sh
469 rm -f ${D}/${libdir}/rpm/pythoneggs.py
470 rm -f ${D}/${libdir}/rpm/macros.d/kernel
471 rm -f ${D}/${libdir}/rpm/macros.d/gstreamer
472 rm -f ${D}/${libdir}/rpm/bin/mgo
473 rm -f ${D}/${libdir}/rpm/bin/dbconvert
474 rm -f ${D}/${libdir}/rpm/bin/pom2spec
475
476 rm -rf ${D}/var/lib/wdj ${D}/var/cache/wdj
477 rm -f ${D}/${libdir}/rpm/bin/api-sanity-checker.pl
478
479}
480
481add_native_wrapper() {
482 create_wrapper ${D}/${bindir}/rpm \
483 RPM_USRLIBRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir', True), d.getVar('bindir', True))}/rpm \
484 RPM_ETCRPM='$'{RPM_ETCRPM-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir', True), d.getVar('bindir', True))}/rpm} \
485 RPM_LOCALEDIRRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir', True), d.getVar('bindir', True))}/locale
486
487 create_wrapper ${D}/${bindir}/rpm2cpio \
488 RPM_USRLIBRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir', True), d.getVar('bindir', True))}/rpm \
489 RPM_ETCRPM='$'{RPM_ETCRPM-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir', True), d.getVar('bindir', True))}/rpm} \
490 RPM_LOCALEDIRRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir', True), d.getVar('bindir', True))}/locale
491
492 create_wrapper ${D}/${bindir}/rpmbuild \
493 RPM_USRLIBRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir', True), d.getVar('bindir', True))}/rpm \
494 RPM_ETCRPM='$'{RPM_ETCRPM-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir', True), d.getVar('bindir', True))}/rpm} \
495 RPM_LOCALEDIRRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir', True), d.getVar('bindir', True))}/locale
496
497 create_wrapper ${D}/${bindir}/rpmconstant \
498 RPM_USRLIBRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir', True), d.getVar('bindir', True))}/rpm \
499 RPM_ETCRPM='$'{RPM_ETCRPM-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir', True), d.getVar('bindir', True))}/rpm} \
500 RPM_LOCALEDIRRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir', True), d.getVar('bindir', True))}/locale
501
502 for rpm_binary in ${D}/${libdir}/rpm/bin/rpm* ${D}/${libdir}/rpm/bin/debugedit; do
503 create_wrapper $rpm_binary \
504 RPM_USRLIBRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir', True), d.getVar('bindir', True))}/rpm \
505 RPM_ETCRPM='$'{RPM_ETCRPM-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir', True), d.getVar('bindir', True))}/rpm} \
506 RPM_LOCALEDIRRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir', True), d.getVar('bindir', True))}/locale
507 done
508}
509
510do_install_append_class-native() {
511 add_native_wrapper
512}
513
514do_install_append_class-nativesdk() {
515 add_native_wrapper
516}
517
518BBCLASSEXTEND = "native nativesdk"