summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rpm/rpm_4.11.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/rpm/rpm_4.11.2.bb')
-rw-r--r--meta/recipes-devtools/rpm/rpm_4.11.2.bb135
1 files changed, 135 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_4.11.2.bb b/meta/recipes-devtools/rpm/rpm_4.11.2.bb
new file mode 100644
index 0000000000..7c67b696a3
--- /dev/null
+++ b/meta/recipes-devtools/rpm/rpm_4.11.2.bb
@@ -0,0 +1,135 @@
1SUMMARY = "The RPM package management system"
2DESCRIPTION = "The RPM Package Manager (RPM) is a powerful command line driven \
3package management system capable of installing, uninstalling, \
4verifying, querying, and updating software packages. Each software \
5package consists of an archive of files along with information about \
6the package like its version, a description, etc."
7
8SUMMARY_${PN}-dev = "Development files for manipulating RPM packages"
9DESCRIPTION_${PN}-dev = "This package contains the RPM C library and header files. These \
10development files will simplify the process of writing programs that \
11manipulate RPM packages and databases. These files are intended to \
12simplify the process of creating graphical package managers or any \
13other tools that need an intimate knowledge of RPM packages in order \
14to function."
15
16SUMMARY_python-rpm = "Python bindings for apps which will manupulate RPM packages"
17DESCRIPTION_python-rpm = "The rpm-python package contains a module that permits applications \
18written in the Python programming language to use the interface \
19supplied by the RPM Package Manager libraries."
20
21HOMEPAGE = "http://www.rpm.org"
22LICENSE = "GPL-2.0+"
23LIC_FILES_CHKSUM ??= "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
24
25DEPENDS = "db libxml2 xz findutils file popt nss bzip2 elfutils patch attr zlib acl gzip make binutils python"
26
27SRC_URI += "http://rpm.org/releases/rpm-4.11.x/${BP}.tar.bz2 \
28 file://use-pkgconfig-for-python.patch \
29 file://remove-db3-from-configure.patch \
30 file://add_RPMSENSE_MISSINGOK_to_rpmmodule.patch \
31 file://support-suggests-tag.patch \
32 file://remove-dir-check.patch \
33 file://disable_shortcircuited.patch \
34 file://fix_libdir.patch \
35 file://rpm-scriptetexechelp.patch \
36 file://pythondeps.sh \
37 file://rpm-CVE-2014-8118.patch \
38 file://rpm-CVE-2013-6435.patch \
39 "
40
41SRC_URI[md5sum] = "876ac9948a88367054f8ddb5c0e87173"
42SRC_URI[sha256sum] = "403f8de632b33846ce5746f429c21a60f40dff9dcb56f1b4118f37a0652a48d4"
43
44inherit autotools-brokensep
45inherit pythonnative
46inherit pkgconfig
47inherit gettext
48
49EXTRA_OECONF += "--host=${HOST_SYS} \
50 --program-prefix= \
51 --prefix=${prefix} \
52 --exec-prefix=${prefix} \
53 --bindir=${prefix}/bin \
54 --sbindir=${prefix}/sbin \
55 --sysconfdir=${sysconfdir} \
56 --datadir=${prefix}/share \
57 --includedir=${prefix}/include \
58 --libdir=${prefix}/lib \
59 --libexecdir=${prefix}/libexec \
60 --localstatedir=${localstatedir} \
61 --sharedstatedir=${prefix}/com \
62 --mandir=${mandir} \
63 --infodir=${infodir} \
64 --disable-dependency-tracking \
65 --with-acl \
66 --without-lua \
67 --without-cap \
68 --enable-shared \
69 --enable-python \
70 --with-external-db \
71 "
72
73CPPFLAGS_append = " `pkg-config --cflags nss`"
74LDFLAGS_append = " -Wl,-Bsymbolic-functions -ffunction-sections"
75CCFLAGS_append = " -fPIC "
76CXXFLAGS_append = " -fPIC "
77CFLAGS_append = " -fPIC -DRPM_VENDOR_WINDRIVER -DRPM_VENDOR_POKY -DRPM_VENDOR_OE "
78
79do_configure_prepend() {
80 rm -rf sqlite
81 rm -f m4/libtool.m4
82 rm -f m4/lt*.m4
83 rm -rf db3/configure*
84}
85
86do_install_append() {
87 mv ${D}/${base_bindir}/rpm ${D}/${bindir}/
88 rmdir ${D}/${base_bindir}
89 rm -f ${D}${prefix}/lib/*.la
90 rm -f ${D}${prefix}/lib/rpm-plugins/*.la
91 rm -f ${D}/${libdir}/python%{with_python_version}/site-packages/*.{a,la}
92 rm -f ${D}/${libdir}/python%{with_python_version}/site-packages/rpm/*.{a,la}
93 rm -fr ${D}/var
94 install -d ${D}${prefix}/lib/rpm/bin
95 ln -s ../debugedit ${D}${prefix}/lib/rpm/bin/debugedit
96 ln -s ../rpmdeps ${D}${prefix}/lib/rpm/bin/rpmdeps-oecore
97 install -m 0755 ${WORKDIR}/pythondeps.sh ${D}/${libdir}/rpm/pythondeps.sh
98}
99
100pkg_postinst_${PN}() {
101
102 [ "x\$D" == "x" ] && ldconfig
103 test -f ${localstatedir}/lib/rpm/Packages || rpm --initdb
104 rm -f ${localstatedir}/lib/rpm/Filemd5s \
105 ${localstatedir}/lib/rpm/Filedigests \
106 ${localstatedir}/lib/rpm/Requireversion \
107 ${localstatedir}/lib/rpm/Provideversion
108
109}
110
111pkg_postrm_${PN}() {
112 [ "x\$D" == "x" ] && ldconfig
113
114}
115
116PACKAGES += "python-${PN}"
117PROVIDES += "python-rpm"
118
119FILES_${PN} += "${libdir}/rpm \
120 ${libdir}/rpm-plugins/exec.so \
121 "
122RDEPENDS_${PN} = "base-files run-postinsts"
123RDEPENDS_${PN}_class-native = "base-files run-postinsts"
124
125FILES_${PN}-dbg += "${libdir}/rpm/.debug/* \
126 ${libdir}/rpm-plugins/.debug/* \
127 ${libdir}/python2.7/site-packages/rpm/.debug/* \
128 "
129
130FILES_${PN}-dev += "${libdir}/python2.7/site-packages/rpm/*.la"
131
132FILES_python-${PN} = "${libdir}/python2.7/site-packages/rpm/*"
133RDEPENDS_python-${PN} = "${PN} python"
134
135BBCLASSEXTEND = "native"