summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu/qemu_1.2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/qemu/qemu_1.2.0.bb')
-rw-r--r--meta/recipes-devtools/qemu/qemu_1.2.0.bb52
1 files changed, 0 insertions, 52 deletions
diff --git a/meta/recipes-devtools/qemu/qemu_1.2.0.bb b/meta/recipes-devtools/qemu/qemu_1.2.0.bb
deleted file mode 100644
index af5eb0349c..0000000000
--- a/meta/recipes-devtools/qemu/qemu_1.2.0.bb
+++ /dev/null
@@ -1,52 +0,0 @@
1require qemu.inc
2
3LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
4 file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913"
5
6SRC_URI = "\
7 http://wiki.qemu.org/download/qemu-${PV}.tar.bz2 \
8 file://powerpc_rom.bin \
9 file://no-strip.patch \
10 file://linker-flags.patch \
11 file://qemu-vmware-vga-depth.patch \
12 file://fix-configure-checks.patch \
13 file://fallback-to-safe-mmap_min_addr.patch \
14 file://larger_default_ram_size.patch \
15 file://arm-bgr.patch \
16 file://remove-hardcoded-libexec.patch \
17 "
18SRC_URI[md5sum] = "78eb1e984f4532aa9f2bdd3c127b5b61"
19SRC_URI[sha256sum] = "c8b84420d9f4869397f84cad2dabd9a475b7723d619a924a873740353e9df936"
20
21PR = "r4"
22
23SRC_URI_append_class-nativesdk = "\
24 file://relocatable_sdk.patch \
25 "
26
27do_configure_prepend_class-nativesdk() {
28 if [ "${@base_contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}" = "" ] ; then
29 # Undo the -lX11 added by linker-flags.patch
30 sed -i 's/-lX11//g' Makefile.target
31 fi
32}
33
34# The following fragment will create a wrapper for qemu-mips user emulation
35# binary in order to work around a segmentation fault issue. Basically, by
36# default, the reserved virtual address space for 32-on-64 bit is set to 4GB.
37# This will trigger a MMU access fault in the virtual CPU. With this change,
38# the qemu-mips works fine.
39# IMPORTANT: This piece needs to be removed once the root cause is fixed!
40do_install_append() {
41 if [ -e "${D}/${bindir}/qemu-mips" ]; then
42 create_wrapper ${D}/${bindir}/qemu-mips \
43 QEMU_RESERVED_VA=0x0
44 fi
45}
46# END of qemu-mips workaround
47
48do_configure_prepend_class-native() {
49 # Undo the -lX11 added by linker-flags.patch, don't assume that host has libX11 installed
50 sed -i 's/-lX11//g' Makefile.target
51}
52