summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu/qemu-system-native_8.2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/qemu/qemu-system-native_8.2.1.bb')
-rw-r--r--meta/recipes-devtools/qemu/qemu-system-native_8.2.1.bb31
1 files changed, 0 insertions, 31 deletions
diff --git a/meta/recipes-devtools/qemu/qemu-system-native_8.2.1.bb b/meta/recipes-devtools/qemu/qemu-system-native_8.2.1.bb
deleted file mode 100644
index 0634b34242..0000000000
--- a/meta/recipes-devtools/qemu/qemu-system-native_8.2.1.bb
+++ /dev/null
@@ -1,31 +0,0 @@
1BPN = "qemu"
2
3require qemu-native.inc
4
5# As some of the files installed by qemu-native and qemu-system-native
6# are the same, we depend on qemu-native to get the full installation set
7# and avoid file clashes
8DEPENDS += "glib-2.0-native zlib-native pixman-native qemu-native"
9
10EXTRA_OECONF:append = " --target-list=${@get_qemu_system_target_list(d)}"
11
12PACKAGECONFIG ??= "fdt alsa kvm pie slirp png \
13 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'virglrenderer epoxy', '', d)} \
14"
15
16# Handle distros such as CentOS 5 32-bit that do not have kvm support
17PACKAGECONFIG:remove = "${@'kvm' if not os.path.exists('/usr/include/linux/kvm.h') else ''}"
18
19do_install:append() {
20 install -Dm 0755 ${WORKDIR}/powerpc_rom.bin ${D}${datadir}/qemu
21
22 # The following is also installed by qemu-native
23 rm -f ${D}${datadir}/qemu/trace-events-all
24 rm -rf ${D}${datadir}/qemu/keymaps
25 rm -rf ${D}${datadir}/icons/
26 rm -rf ${D}${includedir}/qemu-plugin.h
27
28 # Install qmp.py to be used with testimage
29 install -d ${D}${libdir}/qemu-python/qmp/
30 install -D ${S}/python/qemu/qmp/* ${D}${libdir}/qemu-python/qmp/
31}