summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu/qemu-system-native_6.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/qemu/qemu-system-native_6.0.0.bb')
-rw-r--r--meta/recipes-devtools/qemu/qemu-system-native_6.0.0.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-devtools/qemu/qemu-system-native_6.0.0.bb b/meta/recipes-devtools/qemu/qemu-system-native_6.0.0.bb
new file mode 100644
index 0000000000..9d7d0cdceb
--- /dev/null
+++ b/meta/recipes-devtools/qemu/qemu-system-native_6.0.0.bb
@@ -0,0 +1,31 @@
1BPN = "qemu"
2
3inherit python3-dir
4
5require qemu-native.inc
6
7# As some of the files installed by qemu-native and qemu-system-native
8# are the same, we depend on qemu-native to get the full installation set
9# and avoid file clashes
10DEPENDS = "glib-2.0-native zlib-native pixman-native qemu-native bison-native"
11
12EXTRA_OECONF_append = " --target-list=${@get_qemu_system_target_list(d)}"
13
14PACKAGECONFIG ??= "fdt alsa kvm pie \
15 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'virglrenderer glx', '', d)} \
16"
17
18# Handle distros such as CentOS 5 32-bit that do not have kvm support
19PACKAGECONFIG_remove = "${@'kvm' if not os.path.exists('/usr/include/linux/kvm.h') else ''}"
20
21do_install_append() {
22 install -Dm 0755 ${WORKDIR}/powerpc_rom.bin ${D}${datadir}/qemu
23
24 # The following is also installed by qemu-native
25 rm -f ${D}${datadir}/qemu/trace-events-all
26 rm -rf ${D}${datadir}/qemu/keymaps
27 rm -rf ${D}${datadir}/icons/
28
29 # Install qmp.py to be used with testimage
30 install -D ${S}/python/qemu/qmp.py ${D}${PYTHON_SITEPACKAGES_DIR}/qmp.py
31}