summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python_2.6.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python_2.6.6.bb')
-rw-r--r--meta/recipes-devtools/python/python_2.6.6.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/meta/recipes-devtools/python/python_2.6.6.bb b/meta/recipes-devtools/python/python_2.6.6.bb
index 800ba04142..76f32f2481 100644
--- a/meta/recipes-devtools/python/python_2.6.6.bb
+++ b/meta/recipes-devtools/python/python_2.6.6.bb
@@ -1,7 +1,7 @@
1require python.inc 1require python.inc
2DEPENDS = "python-native db gdbm openssl readline sqlite3 zlib" 2DEPENDS = "python-native db gdbm openssl readline sqlite3 zlib"
3DEPENDS_sharprom = "python-native db readline zlib gdbm openssl" 3DEPENDS_sharprom = "python-native db readline zlib gdbm openssl"
4PR = "${INC_PR}.8" 4PR = "${INC_PR}.9"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=38fdd546420fab09ac6bd3d8a1c83eb6" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=38fdd546420fab09ac6bd3d8a1c83eb6"
6 6
7DISTRO_SRC_URI ?= "file://sitecustomize.py" 7DISTRO_SRC_URI ?= "file://sitecustomize.py"
@@ -54,6 +54,9 @@ do_compile() {
54 sed -i -e 's,${includedir},${STAGING_INCDIR},' Makefile 54 sed -i -e 's,${includedir},${STAGING_INCDIR},' Makefile
55 sed -i -e 's,${libdir},${STAGING_LIBDIR},' Makefile 55 sed -i -e 's,${libdir},${STAGING_LIBDIR},' Makefile
56 install -m 0644 Makefile ${STAGING_LIBDIR}/python${PYTHON_MAJMIN}/config/ 56 install -m 0644 Makefile ${STAGING_LIBDIR}/python${PYTHON_MAJMIN}/config/
57 # save copy of it now, because if we do it in do_install and
58 # then call do_install twice we get Makefile.orig == Makefile.sysroot
59 install -m 0644 Makefile Makefile.sysroot
57 60
58 oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/pgen \ 61 oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/pgen \
59 HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python \ 62 HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python \
@@ -75,7 +78,6 @@ do_compile() {
75do_install() { 78do_install() {
76 # make install needs the original Makefile, or otherwise the inclues would 79 # make install needs the original Makefile, or otherwise the inclues would
77 # go to ${D}${STAGING...}/... 80 # go to ${D}${STAGING...}/...
78 install -m 0644 Makefile Makefile.sysroot
79 install -m 0644 Makefile.orig Makefile 81 install -m 0644 Makefile.orig Makefile
80 82
81 oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/pgen \ 83 oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/pgen \
@@ -86,7 +88,6 @@ do_install() {
86 DESTDIR=${D} LIBDIR=${libdir} install 88 DESTDIR=${D} LIBDIR=${libdir} install
87 89
88 install -m 0644 Makefile.sysroot ${D}/${libdir}/python${PYTHON_MAJMIN}/config/Makefile 90 install -m 0644 Makefile.sysroot ${D}/${libdir}/python${PYTHON_MAJMIN}/config/Makefile
89 rm Makefile.sysroot
90 91
91 if [ -e ${WORKDIR}/sitecustomize.py ]; then 92 if [ -e ${WORKDIR}/sitecustomize.py ]; then
92 install -m 0644 ${WORKDIR}/sitecustomize.py ${D}/${libdir}/python${PYTHON_MAJMIN} 93 install -m 0644 ${WORKDIR}/sitecustomize.py ${D}/${libdir}/python${PYTHON_MAJMIN}