summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3_3.7.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3_3.7.4.bb')
-rw-r--r--meta/recipes-devtools/python/python3_3.7.4.bb10
1 files changed, 8 insertions, 2 deletions
diff --git a/meta/recipes-devtools/python/python3_3.7.4.bb b/meta/recipes-devtools/python/python3_3.7.4.bb
index a63abfd6cb..59d7024988 100644
--- a/meta/recipes-devtools/python/python3_3.7.4.bb
+++ b/meta/recipes-devtools/python/python3_3.7.4.bb
@@ -229,7 +229,7 @@ python(){
229 229
230 newpackages=[] 230 newpackages=[]
231 for key in python_manifest: 231 for key in python_manifest:
232 pypackage= pn + '-' + key 232 pypackage = pn + '-' + key
233 233
234 if pypackage not in packages: 234 if pypackage not in packages:
235 # We need to prepend, otherwise python-misc gets everything 235 # We need to prepend, otherwise python-misc gets everything
@@ -249,8 +249,14 @@ python(){
249 for value in python_manifest[key]['rdepends']: 249 for value in python_manifest[key]['rdepends']:
250 # Make it work with or without $PN 250 # Make it work with or without $PN
251 if '${PN}' in value: 251 if '${PN}' in value:
252 value=value.split('-')[1] 252 value=value.split('-', 1)[1]
253 d.appendVar('RDEPENDS_' + pypackage, ' ' + pn + '-' + value) 253 d.appendVar('RDEPENDS_' + pypackage, ' ' + pn + '-' + value)
254
255 for value in python_manifest[key].get('rrecommends', ()):
256 if '${PN}' in value:
257 value=value.split('-', 1)[1]
258 d.appendVar('RRECOMMENDS_' + pypackage, ' ' + pn + '-' + value)
259
254 d.setVar('SUMMARY_' + pypackage, python_manifest[key]['summary']) 260 d.setVar('SUMMARY_' + pypackage, python_manifest[key]['summary'])
255 261
256 # Prepending so to avoid python-misc getting everything 262 # Prepending so to avoid python-misc getting everything