summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3_3.3.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3_3.3.3.bb')
-rw-r--r--meta/recipes-devtools/python/python3_3.3.3.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-devtools/python/python3_3.3.3.bb b/meta/recipes-devtools/python/python3_3.3.3.bb
index 2c1f63f5b8..efa98c09fa 100644
--- a/meta/recipes-devtools/python/python3_3.3.3.bb
+++ b/meta/recipes-devtools/python/python3_3.3.3.bb
@@ -76,7 +76,7 @@ do_configure_prepend() {
76 76
77do_compile() { 77do_compile() {
78 # regenerate platform specific files, because they depend on system headers 78 # regenerate platform specific files, because they depend on system headers
79 cd Lib/plat-linux* 79 cd ${S}/Lib/plat-linux*
80 include=${STAGING_INCDIR} ${STAGING_BINDIR_NATIVE}/python3-native/python3 \ 80 include=${STAGING_INCDIR} ${STAGING_BINDIR_NATIVE}/python3-native/python3 \
81 ${S}/Tools/scripts/h2py.py -i '(u_long)' \ 81 ${S}/Tools/scripts/h2py.py -i '(u_long)' \
82 ${STAGING_INCDIR}/dlfcn.h \ 82 ${STAGING_INCDIR}/dlfcn.h \
@@ -108,7 +108,7 @@ do_compile() {
108 install -m 0644 Makefile Makefile.sysroot 108 install -m 0644 Makefile Makefile.sysroot
109 109
110 export CROSS_COMPILE="${TARGET_PREFIX}" 110 export CROSS_COMPILE="${TARGET_PREFIX}"
111 export PYTHONBUILDDIR="${S}" 111 export PYTHONBUILDDIR="${B}"
112 oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/python3-native/pgen \ 112 oe_runmake HOSTPGEN=${STAGING_BINDIR_NATIVE}/python3-native/pgen \
113 HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python3-native/python3 \ 113 HOSTPYTHON=${STAGING_BINDIR_NATIVE}/python3-native/python3 \
114 STAGING_LIBDIR=${STAGING_LIBDIR} \ 114 STAGING_LIBDIR=${STAGING_LIBDIR} \
@@ -136,7 +136,7 @@ do_install() {
136 install -m 0644 Makefile.orig Makefile 136 install -m 0644 Makefile.orig Makefile
137 137
138 export CROSS_COMPILE="${TARGET_PREFIX}" 138 export CROSS_COMPILE="${TARGET_PREFIX}"
139 export PYTHONBUILDDIR="${S}" 139 export PYTHONBUILDDIR="${B}"
140 install -d ${D}${libdir}/pkgconfig 140 install -d ${D}${libdir}/pkgconfig
141 install -d ${D}${libdir}/python${PYTHON_MAJMIN}/config 141 install -d ${D}${libdir}/python${PYTHON_MAJMIN}/config
142 142