summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-webcolors_1.13.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-webcolors_1.13.bb')
-rw-r--r--meta/recipes-devtools/python/python3-webcolors_1.13.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-webcolors_1.13.bb b/meta/recipes-devtools/python/python3-webcolors_1.13.bb
new file mode 100644
index 0000000000..cea2a971d3
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-webcolors_1.13.bb
@@ -0,0 +1,28 @@
1SUMMARY = "Simple Python module for working with HTML/CSS color definitions."
2HOMEPAGE = "https://pypi.org/project/webcolors/"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=702b1ef12cf66832a88f24c8f2ee9c19"
5
6SRC_URI[sha256sum] = "c225b674c83fa923be93d235330ce0300373d02885cef23238813b0d5668304a"
7
8inherit pypi python_setuptools_build_meta ptest
9
10RDEPENDS:${PN}:class-target = "\
11 python3-stringold \
12"
13
14SRC_URI += " \
15 file://run-ptest \
16"
17
18RDEPENDS:${PN}-ptest += " \
19 python3-pytest \
20 python3-unittest-automake-output \
21"
22
23do_install_ptest() {
24 install -d ${D}${PTEST_PATH}/tests
25 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
26}
27
28BBCLASSEXTEND = "native nativesdk"