summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-urllib3_2.2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-urllib3_2.2.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-urllib3_2.2.1.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-urllib3_2.2.1.bb b/meta/recipes-devtools/python/python3-urllib3_2.2.1.bb
new file mode 100644
index 0000000000..fc1828b4ee
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-urllib3_2.2.1.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Python HTTP library with thread-safe connection pooling, file post support, sanity friendly, and more"
2HOMEPAGE = "https://github.com/shazow/urllib3"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=52d273a3054ced561275d4d15260ecda"
5
6SRC_URI[sha256sum] = "d0570876c61ab9e520d776c38acbbb5b05a776d3f9ff98a5c8fd5162a444cf19"
7
8inherit pypi python_hatchling
9
10RDEPENDS:${PN} += "\
11 python3-certifi \
12 python3-cryptography \
13 python3-email \
14 python3-idna \
15 python3-json \
16 python3-netclient \
17 python3-pyopenssl \
18 python3-threading \
19 python3-logging \
20"
21
22CVE_PRODUCT = "urllib3"
23
24BBCLASSEXTEND = "native nativesdk"