summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-urllib3_1.26.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-urllib3_1.26.14.bb')
-rw-r--r--meta/recipes-devtools/python/python3-urllib3_1.26.14.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-urllib3_1.26.14.bb b/meta/recipes-devtools/python/python3-urllib3_1.26.14.bb
new file mode 100644
index 0000000000..f35a141df2
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-urllib3_1.26.14.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Python HTTP library with thread-safe connection pooling, file post support, sanity friendly, and more"
2HOMEPAGE = "https://github.com/shazow/urllib3"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c2823cb995439c984fd62a973d79815c"
5
6SRC_URI[sha256sum] = "076907bf8fd355cde77728471316625a4d2f7e713c125f51953bb5b3eecf4f72"
7
8inherit pypi setuptools3
9
10RDEPENDS:${PN} += "\
11 ${PYTHON_PN}-certifi \
12 ${PYTHON_PN}-cryptography \
13 ${PYTHON_PN}-email \
14 ${PYTHON_PN}-idna \
15 ${PYTHON_PN}-netclient \
16 ${PYTHON_PN}-pyopenssl \
17 ${PYTHON_PN}-threading \
18 ${PYTHON_PN}-logging \
19"
20
21CVE_PRODUCT = "urllib3"
22
23BBCLASSEXTEND = "native nativesdk"