summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-urllib3_1.26.14.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2023-02-03 09:50:34 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-02-04 17:02:10 +0000
commit69b8b7ef1bd3c2e4a5140aff3de5318b1b292986 (patch)
tree2db94890580c3fb31c34bc01a95b19116b8cadd9 /meta/recipes-devtools/python/python3-urllib3_1.26.14.bb
parent5cba8c7e742adac2ace9522460392d4a1ad49073 (diff)
downloadpoky-69b8b7ef1bd3c2e4a5140aff3de5318b1b292986.tar.gz
python3-urllib3: upgrade 1.26.13 -> 1.26.14
https://github.com/urllib3/urllib3/blob/1.26.14/CHANGES.rst#12614-2023-01-11 1.26.14 (2023-01-11) Fixed parsing of port 0 (zero) returning None, instead of 0. (#2850) Removed deprecated getheaders() calls in contrib module. (From OE-Core rev: 55ab1bf20e6893088acb6460e9004dac8e205559) Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-urllib3_1.26.14.bb')
-rw-r--r--meta/recipes-devtools/python/python3-urllib3_1.26.14.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-urllib3_1.26.14.bb b/meta/recipes-devtools/python/python3-urllib3_1.26.14.bb
new file mode 100644
index 0000000000..f35a141df2
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-urllib3_1.26.14.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Python HTTP library with thread-safe connection pooling, file post support, sanity friendly, and more"
2HOMEPAGE = "https://github.com/shazow/urllib3"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c2823cb995439c984fd62a973d79815c"
5
6SRC_URI[sha256sum] = "076907bf8fd355cde77728471316625a4d2f7e713c125f51953bb5b3eecf4f72"
7
8inherit pypi setuptools3
9
10RDEPENDS:${PN} += "\
11 ${PYTHON_PN}-certifi \
12 ${PYTHON_PN}-cryptography \
13 ${PYTHON_PN}-email \
14 ${PYTHON_PN}-idna \
15 ${PYTHON_PN}-netclient \
16 ${PYTHON_PN}-pyopenssl \
17 ${PYTHON_PN}-threading \
18 ${PYTHON_PN}-logging \
19"
20
21CVE_PRODUCT = "urllib3"
22
23BBCLASSEXTEND = "native nativesdk"