summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-trove-classifiers_2024.5.22.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-trove-classifiers_2024.5.22.bb')
-rw-r--r--meta/recipes-devtools/python/python3-trove-classifiers_2024.5.22.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-trove-classifiers_2024.5.22.bb b/meta/recipes-devtools/python/python3-trove-classifiers_2024.5.22.bb
new file mode 100644
index 0000000000..8876b63e7d
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-trove-classifiers_2024.5.22.bb
@@ -0,0 +1,28 @@
1SUMMARY = "Canonical source for classifiers on PyPI (pypi.org)."
2HOMEPAGE = "https://github.com/pypa/trove-classifiers"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
5
6SRC_URI[sha256sum] = "8a6242bbb5c9ae88d34cf665e816b287d2212973c8777dfaef5ec18d72ac1d03"
7
8PYPI_PACKAGE = "trove_classifiers"
9
10inherit pypi python_setuptools_build_meta ptest
11
12DEPENDS += " python3-calver-native"
13
14SRC_URI += " \
15 file://run-ptest \
16"
17
18RDEPENDS:${PN}-ptest += " \
19 python3-pytest \
20 python3-unittest-automake-output \
21"
22
23do_install_ptest() {
24 install -d ${D}${PTEST_PATH}/tests
25 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
26}
27
28BBCLASSEXTEND = "native nativesdk"