summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-trove-classifiers_2024.3.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-trove-classifiers_2024.3.3.bb')
-rw-r--r--meta/recipes-devtools/python/python3-trove-classifiers_2024.3.3.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-trove-classifiers_2024.3.3.bb b/meta/recipes-devtools/python/python3-trove-classifiers_2024.3.3.bb
new file mode 100644
index 0000000000..b912efcf55
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-trove-classifiers_2024.3.3.bb
@@ -0,0 +1,26 @@
1SUMMARY = "Canonical source for classifiers on PyPI (pypi.org)."
2HOMEPAGE = "https://github.com/pypa/trove-classifiers"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
5
6SRC_URI[sha256sum] = "df7edff9c67ff86b733628998330b180e81d125b1e096536d83ac0fd79673fdc"
7
8inherit pypi python_setuptools_build_meta ptest
9
10DEPENDS += " python3-calver-native"
11
12SRC_URI += " \
13 file://run-ptest \
14"
15
16RDEPENDS:${PN}-ptest += " \
17 python3-pytest \
18 python3-unittest-automake-output \
19"
20
21do_install_ptest() {
22 install -d ${D}${PTEST_PATH}/tests
23 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
24}
25
26BBCLASSEXTEND = "native nativesdk"