summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-testtools_2.7.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-testtools_2.7.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-testtools_2.7.1.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-testtools_2.7.1.bb b/meta/recipes-devtools/python/python3-testtools_2.7.1.bb
new file mode 100644
index 0000000000..cc7e055632
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-testtools_2.7.1.bb
@@ -0,0 +1,20 @@
1SUMMARY = "Extensions to the Python standard library unit testing framework"
2HOMEPAGE = "https://pypi.org/project/testtools/"
3SECTION = "devel/python"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=e2c9d3e8ba7141c83bfef190e0b9379a"
6
7DEPENDS += "python3-hatch-vcs-native"
8
9inherit pypi python_hatchling
10
11SRC_URI[sha256sum] = "df6de96010e29ee21f637a147eabf30d50b25e3841dd1d68f93ee89ce77e366c"
12
13RDEPENDS:${PN} += "\
14 python3-doctest \
15 python3-extras \
16 python3-six \
17 "
18
19BBCLASSEXTEND = "nativesdk"
20