summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-sphinx_7.2.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-sphinx_7.2.6.bb')
-rw-r--r--meta/recipes-devtools/python/python3-sphinx_7.2.6.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-sphinx_7.2.6.bb b/meta/recipes-devtools/python/python3-sphinx_7.2.6.bb
new file mode 100644
index 0000000000..f4ed0720ff
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-sphinx_7.2.6.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Python documentation generator"
2HOMEPAGE = "http://sphinx-doc.org/"
3SECTION = "devel/python"
4LICENSE = "BSD-2-Clause & MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=5eb6ac1b115a1ed24a12d9f15b633993"
6
7SRC_URI[sha256sum] = "9a5160e1ea90688d5963ba09a2dcd8bdd526620edbb65c328728f1b2228d5ab5"
8
9inherit python_flit_core pypi
10UPSTREAM_CHECK_REGEX = "/Sphinx/(?P<pver>(\d+[\.\-_]*)+)/"
11
12do_install:append () {
13 # The cache format of "{None, 'en', 'ja'}" doesn't seem to be consistent (dict ordering?)
14 rm ${D}${libdir}/${PYTHON_DIR}/site-packages/sphinx/writers/__pycache__/*latex*
15}
16
17RDEPENDS:${PN} = "\
18 python3-alabaster \
19 python3-babel \
20 python3-docutils \
21 python3-imagesize \
22 python3-jinja2 \
23 python3-packaging \
24 python3-pygments \
25 python3-requests \
26 python3-snowballstemmer \
27 python3-sphinxcontrib-applehelp \
28 python3-sphinxcontrib-devhelp \
29 python3-sphinxcontrib-htmlhelp \
30 python3-sphinxcontrib-jsmath \
31 python3-sphinxcontrib-qthelp \
32 python3-sphinxcontrib-serializinghtml \
33 "
34
35BBCLASSEXTEND = "native nativesdk"