summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-sphinx-rtd-theme_2.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-sphinx-rtd-theme_2.0.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-sphinx-rtd-theme_2.0.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-sphinx-rtd-theme_2.0.0.bb b/meta/recipes-devtools/python/python3-sphinx-rtd-theme_2.0.0.bb
new file mode 100644
index 0000000000..22b4d96444
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-sphinx-rtd-theme_2.0.0.bb
@@ -0,0 +1,26 @@
1SUMMARY = "Sphinx Theme reader"
2HOMEPAGE = "https://github.com/readthedocs/sphinx_rtd_theme"
3SECTION = "devel/python"
4LICENSE = "MIT & OFL-1.1"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=a1db7d4ef426c2935227264e1d4ae8f9 \
6 file://OFL-License.txt;md5=4534c22e0147eadb6828bd9fe86d4868 \
7 file://Apache-License-2.0.txt;md5=8a75796f0ef19c3f601d69857f5a9a5b"
8
9RDEPENDS:${PN} += " \
10 python3-compile \
11 python3-sphinx \
12 python3-sphinxcontrib-jquery \
13"
14
15PYPI_PACKAGE = "sphinx_rtd_theme"
16
17SRC_URI[sha256sum] = "bd5d7b80622406762073a04ef8fadc5f9151261563d47027de09910ce03afe6b"
18UPSTREAM_CHECK_REGEX ?= "/sphinx-rtd-theme/(?P<pver>(\d+[\.\-_]*)+)/"
19
20inherit setuptools3 pypi
21
22#Fake out the setup scipt
23export CI = "True"
24export TOX_ENV_NAME = "True"
25
26BBCLASSEXTEND = "native nativesdk"