summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-smmap_6.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-smmap_6.0.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-smmap_6.0.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-smmap_6.0.0.bb b/meta/recipes-devtools/python/python3-smmap_6.0.0.bb
new file mode 100644
index 0000000000..6abed1205f
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-smmap_6.0.0.bb
@@ -0,0 +1,19 @@
1SUMMARY = "Python implementation of a sliding window memory map manager"
2DESCRIPTION = "A pure Python implementation of a sliding memory map to \
3help unifying memory mapped access on 32 and 64 bit systems and to help \
4managing resources more efficiently."
5HOMEPAGE = "http://github.com/gitpython-developers/GitPython"
6SECTION = "devel/python"
7LICENSE = "BSD-3-Clause"
8LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e910b35b0ef4e1f665b9a75d6afb7709"
9
10inherit pypi setuptools3
11
12PYPI_PACKAGE = "smmap"
13
14SRC_URI[sha256sum] = "8d79028ea6cc131da5eab099a5d95a998d43c6779956fffe3b455040911076da"
15
16RDEPENDS:${PN} += "python3-codecs \
17 python3-mmap \
18"
19BBCLASSEXTEND = "native nativesdk"