summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-setuptools_69.5.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-setuptools_69.5.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-setuptools_69.5.1.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-setuptools_69.5.1.bb b/meta/recipes-devtools/python/python3-setuptools_69.5.1.bb
new file mode 100644
index 0000000000..8261b09d16
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-setuptools_69.5.1.bb
@@ -0,0 +1,55 @@
1SUMMARY = "Download, build, install, upgrade, and uninstall Python packages"
2HOMEPAGE = "https://pypi.org/project/setuptools"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=141643e11c48898150daa83802dbc65f"
6
7inherit pypi python_setuptools_build_meta
8
9SRC_URI:append:class-native = " file://0001-conditionally-do-not-fetch-code-by-easy_install.patch"
10
11SRC_URI += " \
12 file://0001-_distutils-sysconfig.py-make-it-possible-to-substite.patch"
13
14SRC_URI[sha256sum] = "6c1fccdac05a97e598fb0ae3bbed5904ccb317337a51139dcd51453611bbb987"
15
16DEPENDS += "python3"
17
18RDEPENDS:${PN} = "\
19 python3-2to3 \
20 python3-compile \
21 python3-compression \
22 python3-ctypes \
23 python3-email \
24 python3-html \
25 python3-json \
26 python3-netserver \
27 python3-numbers \
28 python3-pickle \
29 python3-pkg-resources \
30 python3-pkgutil \
31 python3-plistlib \
32 python3-shell \
33 python3-stringold \
34 python3-threading \
35 python3-unittest \
36 python3-xml \
37"
38
39BBCLASSEXTEND = "native nativesdk"
40
41# The pkg-resources module can be used by itself, without the package downloader
42# and easy_install. Ship it in a separate package so that it can be used by
43# minimal distributions.
44PACKAGES =+ "python3-pkg-resources "
45FILES:python3-pkg-resources = "${PYTHON_SITEPACKAGES_DIR}/pkg_resources/*"
46RDEPENDS:python3-pkg-resources = "\
47 python3-compression \
48 python3-email \
49 python3-plistlib \
50 python3-pprint \
51"
52
53# This used to use the bootstrap install which didn't compile. Until we bump the
54# tmpdir version we can't compile the native otherwise the sysroot unpack fails
55INSTALL_WHEEL_COMPILE_BYTECODE:class-native = "--no-compile-bytecode"