summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-setuptools_58.5.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-setuptools_58.5.3.bb')
-rw-r--r--meta/recipes-devtools/python/python3-setuptools_58.5.3.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-setuptools_58.5.3.bb b/meta/recipes-devtools/python/python3-setuptools_58.5.3.bb
new file mode 100644
index 0000000000..ddc3fca354
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-setuptools_58.5.3.bb
@@ -0,0 +1,58 @@
1SUMMARY = "Download, build, install, upgrade, and uninstall Python packages"
2HOMEPAGE = "https://pypi.org/project/setuptools"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;beginline=1;endline=19;md5=7a7126e068206290f3fe9f8d6c713ea6"
6
7inherit pypi setuptools3
8
9SRC_URI:append:class-native = " file://0001-conditionally-do-not-fetch-code-by-easy_install.patch"
10
11SRC_URI += "\
12 file://0001-change-shebang-to-python3.patch \
13 file://0001-_distutils-sysconfig-append-STAGING_LIBDIR-python-sy.patch \
14"
15
16SRC_URI[sha256sum] = "dae6b934a965c8a59d6d230d3867ec408bb95e73bd538ff77e71fedf1eaca729"
17
18DEPENDS += "${PYTHON_PN}"
19
20RDEPENDS:${PN} = "\
21 ${PYTHON_PN}-2to3 \
22 ${PYTHON_PN}-compile \
23 ${PYTHON_PN}-compression \
24 ${PYTHON_PN}-ctypes \
25 ${PYTHON_PN}-distutils \
26 ${PYTHON_PN}-email \
27 ${PYTHON_PN}-html \
28 ${PYTHON_PN}-json \
29 ${PYTHON_PN}-netserver \
30 ${PYTHON_PN}-numbers \
31 ${PYTHON_PN}-pickle \
32 ${PYTHON_PN}-pkg-resources \
33 ${PYTHON_PN}-pkgutil \
34 ${PYTHON_PN}-plistlib \
35 ${PYTHON_PN}-shell \
36 ${PYTHON_PN}-stringold \
37 ${PYTHON_PN}-threading \
38 ${PYTHON_PN}-unittest \
39 ${PYTHON_PN}-xml \
40"
41
42do_install:prepend() {
43 install -d ${D}${PYTHON_SITEPACKAGES_DIR}
44}
45
46BBCLASSEXTEND = "native nativesdk"
47
48# The pkg-resources module can be used by itself, without the package downloader
49# and easy_install. Ship it in a separate package so that it can be used by
50# minimal distributions.
51PACKAGES =+ "${PYTHON_PN}-pkg-resources "
52FILES:${PYTHON_PN}-pkg-resources = "${PYTHON_SITEPACKAGES_DIR}/pkg_resources/*"
53RDEPENDS:${PYTHON_PN}-pkg-resources = "\
54 ${PYTHON_PN}-compression \
55 ${PYTHON_PN}-email \
56 ${PYTHON_PN}-plistlib \
57 ${PYTHON_PN}-pprint \
58"