summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-setuptools_49.2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-setuptools_49.2.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-setuptools_49.2.1.bb65
1 files changed, 65 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-setuptools_49.2.1.bb b/meta/recipes-devtools/python/python3-setuptools_49.2.1.bb
new file mode 100644
index 0000000000..53a121db11
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-setuptools_49.2.1.bb
@@ -0,0 +1,65 @@
1SUMMARY = "Download, build, install, upgrade, and uninstall Python packages"
2HOMEPAGE = "https://pypi.org/project/setuptools"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;beginline=1;endline=19;md5=9a33897f1bca1160d7aad3835152e158"
6
7PYPI_PACKAGE_EXT = "zip"
8
9inherit pypi setuptools3
10
11SRC_URI_append_class-native = " file://0001-conditionally-do-not-fetch-code-by-easy_install.patch"
12
13SRC_URI += "file://0001-change-shebang-to-python3.patch"
14
15SRC_URI[sha256sum] = "88094d17c8d273390659a72e9d93374cd7bfd188c12bf2747b306e2bed48df18"
16
17DEPENDS += "${PYTHON_PN}"
18
19RDEPENDS_${PN} = "\
20 ${PYTHON_PN}-2to3 \
21 ${PYTHON_PN}-compile \
22 ${PYTHON_PN}-compression \
23 ${PYTHON_PN}-ctypes \
24 ${PYTHON_PN}-distutils \
25 ${PYTHON_PN}-email \
26 ${PYTHON_PN}-html \
27 ${PYTHON_PN}-json \
28 ${PYTHON_PN}-netserver \
29 ${PYTHON_PN}-numbers \
30 ${PYTHON_PN}-pickle \
31 ${PYTHON_PN}-pkgutil \
32 ${PYTHON_PN}-plistlib \
33 ${PYTHON_PN}-shell \
34 ${PYTHON_PN}-stringold \
35 ${PYTHON_PN}-threading \
36 ${PYTHON_PN}-unittest \
37 ${PYTHON_PN}-xml \
38"
39
40do_install_prepend() {
41 install -d ${D}${PYTHON_SITEPACKAGES_DIR}
42}
43
44do_install_append() {
45 mv ${D}${bindir}/easy_install ${D}${bindir}/easy3_install
46}
47
48BBCLASSEXTEND = "native nativesdk"
49
50# The pkg-resources module can be used by itself, without the package downloader
51# and easy_install. Ship it in a separate package so that it can be used by
52# minimal distributions.
53PACKAGES =+ "${PYTHON_PN}-pkg-resources "
54FILES_${PYTHON_PN}-pkg-resources = "${PYTHON_SITEPACKAGES_DIR}/pkg_resources/*"
55RDEPENDS_${PYTHON_PN}-pkg-resources = "\
56 ${PYTHON_PN}-compression \
57 ${PYTHON_PN}-email \
58 ${PYTHON_PN}-plistlib \
59 ${PYTHON_PN}-pprint \
60"
61# Due to the way OE-Core implemented native recipes, the native class cannot
62# have a dependency on something that is not a recipe name. Work around that by
63# manually setting RPROVIDES.
64RDEPENDS_${PN}_append = " ${PYTHON_PN}-pkg-resources"
65RPROVIDES_append_class-native = " ${PYTHON_PN}-pkg-resources-native"