summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-setuptools_36.2.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-setuptools_36.2.7.bb')
-rw-r--r--meta/recipes-devtools/python/python3-setuptools_36.2.7.bb7
1 files changed, 1 insertions, 6 deletions
diff --git a/meta/recipes-devtools/python/python3-setuptools_36.2.7.bb b/meta/recipes-devtools/python/python3-setuptools_36.2.7.bb
index 63f241809e..a7bca97402 100644
--- a/meta/recipes-devtools/python/python3-setuptools_36.2.7.bb
+++ b/meta/recipes-devtools/python/python3-setuptools_36.2.7.bb
@@ -4,15 +4,10 @@ DEPENDS += "python3"
4DEPENDS_class-native += "python3-native" 4DEPENDS_class-native += "python3-native"
5DEPENDS_class-nativesdk += "nativesdk-python3" 5DEPENDS_class-nativesdk += "nativesdk-python3"
6 6
7inherit distutils3 7inherit setuptools3
8 8
9DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${PYTHON_SITEPACKAGES_DIR}"
10
11# The installer puts the wrong path in the setuptools.pth file. Correct it.
12do_install_append() { 9do_install_append() {
13 rm ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
14 mv ${D}${bindir}/easy_install ${D}${bindir}/easy3_install 10 mv ${D}${bindir}/easy_install ${D}${bindir}/easy3_install
15 echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
16} 11}
17 12
18RDEPENDS_${PN}_class-native = "\ 13RDEPENDS_${PN}_class-native = "\