summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-setuptools-scm_8.0.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-setuptools-scm_8.0.4.bb')
-rw-r--r--meta/recipes-devtools/python/python3-setuptools-scm_8.0.4.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-setuptools-scm_8.0.4.bb b/meta/recipes-devtools/python/python3-setuptools-scm_8.0.4.bb
new file mode 100644
index 0000000000..64b5050c3b
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-setuptools-scm_8.0.4.bb
@@ -0,0 +1,31 @@
1SUMMARY = "the blessed package to manage your versions by scm tags"
2HOMEPAGE = "https://pypi.org/project/setuptools-scm/"
3DESCRIPTION = "setuptools_scm handles managing your Python package \
4versions in SCM metadata instead of declaring them as the version \
5argument or in a SCM managed file."
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=838c366f69b72c5df05c96dff79b35f2"
8
9SRC_URI[sha256sum] = "b5f43ff6800669595193fd09891564ee9d1d7dcb196cab4b2506d53a2e1c95c7"
10
11inherit pypi python_setuptools_build_meta
12
13UPSTREAM_CHECK_REGEX = "scm-(?P<pver>.*)\.tar"
14
15DEPENDS += "python3-tomli-native python3-packaging-native python3-typing-extensions-native"
16
17RDEPENDS:${PN} = "\
18 python3-packaging \
19 python3-pip \
20 python3-pyparsing \
21 python3-setuptools \
22 python3-tomli \
23 python3-typing-extensions \
24"
25
26RDEPENDS:${PN}:append:class-target = " \
27 python3-debugger \
28 python3-json \
29"
30
31BBCLASSEXTEND = "native nativesdk"