summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-setuptools-rust_1.9.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-setuptools-rust_1.9.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-setuptools-rust_1.9.0.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-setuptools-rust_1.9.0.bb b/meta/recipes-devtools/python/python3-setuptools-rust_1.9.0.bb
new file mode 100644
index 0000000000..8eb2513d69
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-setuptools-rust_1.9.0.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Setuptools Rust extension plugin"
2DESCRIPTION = "setuptools-rust is a plugin for setuptools to build Rust \
3Python extensions implemented with PyO3 or rust-cpython.\
4\
5Compile and distribute Python extensions written in Rust as easily as if they were written in C."
6HOMEPAGE = "https://github.com/PyO3/setuptools-rust"
7BUGTRACKER = "https://github.com/PyO3/setuptools-rust/issues"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=011cd92e702dd9e6b1a26157b6fd53f5"
11
12SRC_URI = "${PYPI_SRC_URI} \
13 https://files.pythonhosted.org/packages/67/08/e1aa2c582c62ac76e4d60f8e454bd3bba933781a06a88b4e38797445822a/setuptools-rust-${PV}.tar.gz \
14 "
15SRC_URI[sha256sum] = "704df0948f2e4cc60c2596ad6e840ea679f4f43e58ed4ad0c1857807240eab96"
16
17inherit cargo pypi python_setuptools_build_meta
18
19DEPENDS += "python3-setuptools-scm-native python3-wheel-native"
20# remove when https://github.com/PyO3/setuptools-rust/commit/7ced8d2a8f36e1b4fc41b5544636defb7bd44bdf
21# is included
22DEPENDS += "python3-semantic-version-native"
23
24RDEPENDS:${PN} += " \
25 python3-json \
26 python3-semantic-version \
27 python3-setuptools \
28 python3-setuptools-scm \
29 python3-shell \
30 python3-toml \
31 python3-typing-extensions \
32 python3-wheel \
33"
34
35BBCLASSEXTEND = "native nativesdk"