summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-scons_4.7.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-scons_4.7.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-scons_4.7.0.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-scons_4.7.0.bb b/meta/recipes-devtools/python/python3-scons_4.7.0.bb
new file mode 100644
index 0000000000..bba6c799d4
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-scons_4.7.0.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Software Construction tool (make/autotools replacement)"
2HOMEPAGE = "https://github.com/SCons/scons"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=d903b0b8027f461402bac9b5169b36f7"
6
7SRC_URI += " file://0001-Fix-man-page-installation.patch"
8SRC_URI[sha256sum] = "d8b617f6610a73e46509de70dcf82f76861b79762ff602d546f4e80918ec81f3"
9
10PYPI_PACKAGE = "SCons"
11
12inherit pypi setuptools3
13
14RDEPENDS:${PN}:class-target = "\
15 python3-core \
16 python3-compression \
17 python3-fcntl \
18 python3-importlib-metadata \
19 python3-io \
20 python3-json \
21 python3-shell \
22 python3-pickle \
23 python3-pkg-resources \
24 python3-pprint \
25 "
26
27do_install:append() {
28 install -d ${D}${mandir}/man1
29 mv ${D}${prefix}/scons*.1 ${D}${mandir}/man1/
30}
31
32do_install:append:class-native() {
33 create_wrapper ${D}${bindir}/scons SCONS_LIB_DIR='${STAGING_DIR_HOST}/${PYTHON_SITEPACKAGES_DIR}' PYTHONNOUSERSITE='1'
34}
35
36BBCLASSEXTEND = "native"