summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-ruamel-yaml_0.18.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-ruamel-yaml_0.18.6.bb')
-rw-r--r--meta/recipes-devtools/python/python3-ruamel-yaml_0.18.6.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-ruamel-yaml_0.18.6.bb b/meta/recipes-devtools/python/python3-ruamel-yaml_0.18.6.bb
new file mode 100644
index 0000000000..197bf91d6c
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-ruamel-yaml_0.18.6.bb
@@ -0,0 +1,23 @@
1SUMMARY = "YAML parser/emitter that supports roundtrip preservation of comments, seq/map flow style, and map key order."
2HOMEPAGE = "https://pypi.org/project/ruamel.yaml/"
3
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=30cbbccd94bf3a2b0285ec35671a1938"
6
7PYPI_PACKAGE = "ruamel.yaml"
8
9inherit pypi setuptools3
10
11SRC_URI[sha256sum] = "8b27e6a217e786c6fbe5634d8f3f11bc63e0f80f6a5890f28863d9c45aac311b"
12
13RDEPENDS:${PN} += "\
14 python3-shell \
15 python3-datetime \
16 python3-netclient \
17"
18
19do_install:prepend() {
20 export RUAMEL_NO_PIP_INSTALL_CHECK=1
21}
22
23BBCLASSEXTEND = "native nativesdk"