summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-requests_2.31.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-requests_2.31.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-requests_2.31.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-requests_2.31.0.bb b/meta/recipes-devtools/python/python3-requests_2.31.0.bb
new file mode 100644
index 0000000000..df48cd54c3
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-requests_2.31.0.bb
@@ -0,0 +1,26 @@
1SUMMARY = "Python HTTP for Humans."
2HOMEPAGE = "http://python-requests.org"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
5
6SRC_URI[sha256sum] = "942c5a758f98d790eaed1a29cb6eefc7ffb0d1cf7af05c3d2791656dbd6ad1e1"
7
8inherit pypi setuptools3
9
10RDEPENDS:${PN} += " \
11 python3-email \
12 python3-json \
13 python3-ndg-httpsclient \
14 python3-netserver \
15 python3-pyasn1 \
16 python3-pyopenssl \
17 python3-pysocks \
18 python3-urllib3 \
19 python3-chardet \
20 python3-idna \
21 python3-compression \
22"
23
24CVE_PRODUCT = "requests"
25
26BBCLASSEXTEND = "native nativesdk"