summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-rdflib_7.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-rdflib_7.0.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-rdflib_7.0.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-rdflib_7.0.0.bb b/meta/recipes-devtools/python/python3-rdflib_7.0.0.bb
new file mode 100644
index 0000000000..4057c1dbbc
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-rdflib_7.0.0.bb
@@ -0,0 +1,21 @@
1SUMMARY = "RDFLib is a pure Python package for working with RDF"
2HOMEPAGE = "https://github.com/RDFLib/rdflib"
3SECTION = "devel/python"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=37d489c0cefe52a17e1d5007e196464a"
6
7SRC_URI[sha256sum] = "9995eb8569428059b8c1affd26b25eac510d64f5043d9ce8c84e0d0036e995ae"
8
9inherit pypi python_poetry_core
10
11RDEPENDS:${PN} += " \
12 python3-isodate \
13 python3-pyparsing \
14 python3-logging \
15 python3-numbers \
16 python3-xml \
17 python3-compression \
18 python3-core \
19"
20
21BBCLASSEXTEND = "native nativesdk"