summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pyyaml_6.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-pyyaml_6.0.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pyyaml_6.0.1.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pyyaml_6.0.1.bb b/meta/recipes-devtools/python/python3-pyyaml_6.0.1.bb
new file mode 100644
index 0000000000..3388312557
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pyyaml_6.0.1.bb
@@ -0,0 +1,40 @@
1SUMMARY = "Python support for YAML"
2DEPENDS += "libyaml python3-cython-native"
3HOMEPAGE = "https://pyyaml.org/"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=6d8242660a8371add5fe547adf083079"
7
8PYPI_PACKAGE = "PyYAML"
9
10inherit pypi python_setuptools_build_meta
11
12SRC_URI += "file://0001-Fix-builds-with-Cython-3.patch"
13SRC_URI[sha256sum] = "bfdf460b1736c775f2ba9f6a92bca30bc2095067b8a9d77876d1fad6cc3b4a43"
14
15PACKAGECONFIG ?= "libyaml"
16PACKAGECONFIG[libyaml] = "--with-libyaml,--without-libyaml,libyaml"
17
18RDEPENDS:${PN} += "\
19 python3-datetime \
20 python3-netclient \
21"
22
23inherit ptest
24SRC_URI += "\
25 https://raw.githubusercontent.com/yaml/pyyaml/a98fd6088e81d7aca571220c966bbfe2ac43c335/tests/test_dump_load.py;name=test \
26 file://run-ptest \
27"
28SRC_URI[test.sha256sum] = "b6a8a2825d89fdc8aee226560f66b8196e872012a0ea7118cbef1a832359434a"
29
30RDEPENDS:${PN}-ptest += " \
31 python3-pytest \
32 python3-unittest-automake-output \
33"
34
35do_install_ptest() {
36 install -d ${D}${PTEST_PATH}/tests
37 cp -rf ${WORKDIR}/test_dump_load.py ${D}${PTEST_PATH}/tests/
38}
39
40BBCLASSEXTEND = "native nativesdk"