summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pytz_2024.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-pytz_2024.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pytz_2024.1.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pytz_2024.1.bb b/meta/recipes-devtools/python/python3-pytz_2024.1.bb
new file mode 100644
index 0000000000..158e800fed
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pytz_2024.1.bb
@@ -0,0 +1,36 @@
1SUMMARY = "World timezone definitions, modern and historical"
2HOMEPAGE = "http://pythonhosted.org/pytz"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=1a67fc46c1b596cce5d21209bbe75999"
5
6inherit pypi setuptools3 ptest
7
8SRC_URI[sha256sum] = "2a29735ea9c18baf14b448846bde5a48030ed267578472d8955cd0e7443a9812"
9
10RDEPENDS:${PN}:class-target += "\
11 python3-datetime \
12 python3-doctest \
13 python3-io \
14 python3-pickle \
15 python3-pprint \
16 python3-threading \
17"
18
19BBCLASSEXTEND = "native nativesdk"
20
21SRC_URI += " \
22 file://run-ptest \
23"
24
25RDEPENDS:${PN}-ptest += " \
26 python3-pytest \
27 python3-unittest-automake-output \
28"
29
30do_install_ptest() {
31 install -d ${D}${PTEST_PATH}/pytz
32 install -d ${D}${PTEST_PATH}/pytz/tests
33 cp -rf ${S}/pytz/tests/* ${D}${PTEST_PATH}/pytz/tests/
34 cp -f ${S}/README.rst ${D}${PTEST_PATH}/
35
36}