summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pytest_7.3.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-pytest_7.3.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pytest_7.3.1.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pytest_7.3.1.bb b/meta/recipes-devtools/python/python3-pytest_7.3.1.bb
new file mode 100644
index 0000000000..9965844d1a
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pytest_7.3.1.bb
@@ -0,0 +1,40 @@
1SUMMARY = "Simple powerful testing with python"
2HOMEPAGE = "https://pypi.org/project/pytest/"
3DESCRIPTION = "The pytest framework makes it easy to write small tests, yet scales to support complex functional testing for applications and libraries."
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=bd27e41b6550fe0fc45356d1d81ee37c"
7
8SRC_URI[sha256sum] = "434afafd78b1d78ed0addf160ad2b77a30d35d4bdf8af234fe621919d9ed15e3"
9
10DEPENDS += "python3-setuptools-scm-native"
11
12inherit update-alternatives pypi python_setuptools_build_meta
13
14RDEPENDS:${PN} += " \
15 ${PYTHON_PN}-atomicwrites \
16 ${PYTHON_PN}-attrs \
17 ${PYTHON_PN}-debugger \
18 ${PYTHON_PN}-doctest \
19 ${PYTHON_PN}-importlib-metadata \
20 ${PYTHON_PN}-iniconfig \
21 ${PYTHON_PN}-json \
22 ${PYTHON_PN}-more-itertools \
23 ${PYTHON_PN}-packaging \
24 ${PYTHON_PN}-pathlib2 \
25 ${PYTHON_PN}-pluggy \
26 ${PYTHON_PN}-py \
27 ${PYTHON_PN}-setuptools \
28 ${PYTHON_PN}-six \
29 ${PYTHON_PN}-wcwidth \
30"
31
32ALTERNATIVE:${PN} += "py.test pytest"
33
34NATIVE_LINK_NAME[pytest] = "${bindir}/pytest"
35ALTERNATIVE_TARGET[pytest] = "${bindir}/pytest"
36
37ALTERNATIVE_LINK_NAME[py.test] = "${bindir}/py.test"
38ALTERNATIVE_TARGET[py.test] = "${bindir}/py.test"
39
40BBCLASSEXTEND = "native nativesdk"