summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pysocks_1.7.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-pysocks_1.7.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pysocks_1.7.1.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pysocks_1.7.1.bb b/meta/recipes-devtools/python/python3-pysocks_1.7.1.bb
new file mode 100644
index 0000000000..7f2c217f19
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pysocks_1.7.1.bb
@@ -0,0 +1,20 @@
1SUMMARY = "A Python SOCKS client module"
2HOMEPAGE = "http://python-requests.org"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=1d457bcffb9661b45f799d4efee72f16"
5
6SRC_URI[md5sum] = "89b1a6865c61bae67a32417517612ee6"
7SRC_URI[sha256sum] = "3f8804571ebe159c380ac6de37643bb4685970655d3bba243530d6558b799aa0"
8
9PYPI_PACKAGE = "PySocks"
10inherit pypi setuptools3
11
12RDEPENDS:${PN}:class-target += "\
13 python3-email \
14 python3-io \
15 python3-logging \
16 python3-netclient \
17 python3-shell \
18"
19
20BBCLASSEXTEND = "native nativesdk"