summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pyproject-hooks_1.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-pyproject-hooks_1.0.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pyproject-hooks_1.0.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pyproject-hooks_1.0.0.bb b/meta/recipes-devtools/python/python3-pyproject-hooks_1.0.0.bb
new file mode 100644
index 0000000000..c3f1fb75ed
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pyproject-hooks_1.0.0.bb
@@ -0,0 +1,24 @@
1SUMMARY = "A low-level library for calling build-backends in pyproject.toml-based projects"
2HOMEPAGE = "https://github.com/pypa/pyproject-hooks"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=aad69c93f605003e3342b174d9b0708c"
5
6SRC_URI[sha256sum] = "f271b298b97f5955d53fb12b72c1fb1948c22c1a6b70b315c54cedaca0264ef5"
7
8inherit pypi python_flit_core
9
10PYPI_PACKAGE = "pyproject_hooks"
11
12BBCLASSEXTEND = "native nativesdk"
13
14# Bootstrap the native build
15DEPENDS:remove:class-native = "python3-build-native"
16
17RDEPENDS:${PN} += " \
18 python3-io \
19 python3-json \
20"
21
22do_compile:class-native () {
23 python_flit_core_do_manual_build
24}