summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pyopenssl_24.1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-pyopenssl_24.1.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pyopenssl_24.1.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pyopenssl_24.1.0.bb b/meta/recipes-devtools/python/python3-pyopenssl_24.1.0.bb
new file mode 100644
index 0000000000..e714ad838e
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pyopenssl_24.1.0.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Simple Python wrapper around the OpenSSL library"
2HOMEPAGE = "https://pyopenssl.org/"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
5
6DEPENDS += "openssl python3-cryptography"
7
8SRC_URI[sha256sum] = "cabed4bfaa5df9f1a16c0ef64a0cb65318b5cd077a7eda7d6970131ca2f41a6f"
9
10PYPI_PACKAGE = "pyOpenSSL"
11inherit pypi setuptools3
12
13PACKAGES =+ "${PN}-tests"
14FILES:${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/OpenSSL/test"
15
16RDEPENDS:${PN}:class-target = " \
17 python3-cryptography \
18 python3-six \
19 python3-threading \
20"
21RDEPENDS:${PN}-tests = "${PN}"
22
23BBCLASSEXTEND = "native nativesdk"