summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pygobject_3.48.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-pygobject_3.48.2.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pygobject_3.48.2.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pygobject_3.48.2.bb b/meta/recipes-devtools/python/python3-pygobject_3.48.2.bb
new file mode 100644
index 0000000000..3d83a8a1c2
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pygobject_3.48.2.bb
@@ -0,0 +1,39 @@
1SUMMARY = "Python GObject bindings"
2HOMEPAGE = "https://gitlab.gnome.org/GNOME/pygobject"
3DESCRIPTION = "PyGObject is a Python package which provides bindings for GObject based libraries such as GTK, GStreamer, WebKitGTK, GLib, GIO and many more."
4SECTION = "devel/python"
5LICENSE = "LGPL-2.1-only"
6LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7"
7
8GIR_MESON_OPTION = ""
9
10inherit gnomebase setuptools3-base gobject-introspection upstream-version-is-even
11
12python() {
13 if d.getVar('CLASSOVERRIDE') == "class-target" and not bb.utils.to_boolean(d.getVar("GI_DATA_ENABLED")):
14 raise bb.parse.SkipRecipe("GI not available")
15}
16
17DEPENDS += "python3 glib-2.0"
18
19SRCNAME="pygobject"
20
21SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/${SRCNAME}/${@gnome_verdir("${PV}")}/${SRCNAME}-${PV}.tar.xz"
22SRC_URI[sha256sum] = "0794aeb4a9be31a092ac20621b5f54ec280f9185943d328b105cdae6298ad1a7"
23
24S = "${WORKDIR}/${SRCNAME}-${PV}"
25
26PACKAGECONFIG ??= "${@bb.utils.contains_any('DISTRO_FEATURES', [ 'directfb', 'wayland', 'x11' ], 'cairo', '', d)}"
27
28RDEPENDS:${PN} += " \
29 python3-io \
30 python3-pkgutil \
31"
32
33# python3-pycairo is checked on configuration -> DEPENDS
34# we don't link against python3-pycairo -> RDEPENDS
35PACKAGECONFIG[cairo] = "-Dpycairo=enabled,-Dpycairo=disabled, cairo python3-pycairo, python3-pycairo"
36PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false,"
37
38BBCLASSEXTEND = "native"
39PACKAGECONFIG:class-native = ""