summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pygobject_3.24.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-pygobject_3.24.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pygobject_3.24.1.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pygobject_3.24.1.bb b/meta/recipes-devtools/python/python3-pygobject_3.24.1.bb
new file mode 100644
index 0000000000..5795ae31da
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pygobject_3.24.1.bb
@@ -0,0 +1,31 @@
1SUMMARY = "Python GObject bindings"
2SECTION = "devel/python"
3LICENSE = "LGPLv2.1"
4LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7"
5
6inherit autotools pkgconfig gnomebase distutils3-base gobject-introspection upstream-version-is-even
7
8DEPENDS += "gnome-common-native python3 glib-2.0"
9
10SRCNAME="pygobject"
11SRC_URI = " \
12 http://ftp.gnome.org/pub/GNOME/sources/${SRCNAME}/${@gnome_verdir("${PV}")}/${SRCNAME}-${PV}.tar.xz \
13 file://0001-configure.ac-add-sysroot-path-to-GI_DATADIR-don-t-se.patch \
14"
15
16SRC_URI[md5sum] = "69a843311d0f0385dff376e11a2d83d2"
17SRC_URI[sha256sum] = "a628a95aa0909e13fb08230b1b98fc48adef10b220932f76d62f6821b3fdbffd"
18
19S = "${WORKDIR}/${SRCNAME}-${PV}"
20
21
22PACKAGECONFIG ??= "${@bb.utils.contains_any('DISTRO_FEATURES', [ 'directfb', 'wayland', 'x11' ], 'cairo', '', d)}"
23
24# python3-pycairo is checked on configuration -> DEPENDS
25# we don't link against python3-pycairo -> RDEPENDS
26PACKAGECONFIG[cairo] = "--enable-cairo,--disable-cairo,cairo python3-pycairo, python3-pycairo"
27
28RDEPENDS_${PN} += "python3-setuptools python3-importlib"
29
30BBCLASSEXTEND = "native"
31PACKAGECONFIG_class-native = ""