summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pycparser_2.22.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-pycparser_2.22.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pycparser_2.22.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pycparser_2.22.bb b/meta/recipes-devtools/python/python3-pycparser_2.22.bb
new file mode 100644
index 0000000000..9a5abc42bd
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pycparser_2.22.bb
@@ -0,0 +1,21 @@
1SUMMARY = "Parser of the C language, written in pure Python"
2HOMEPAGE = "https://github.com/eliben/pycparser"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=9761c3ffee7ba99c60dca0408fd3262b"
5
6SRC_URI[sha256sum] = "491c8be9c040f5390f5bf44a5b07752bd07f56edf992381b05c701439eec10f6"
7
8inherit pypi setuptools3
9
10BBCLASSEXTEND = "native nativesdk"
11
12RDEPENDS:${PN}:class-target += "\
13 python3-netclient \
14 python3-ply \
15 python3-pprint \
16 "
17
18RSUGGESTS:${PN}:class-target += "\
19 cpp \
20 cpp-symlinks \
21 "