summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-ply_3.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-ply_3.11.bb')
-rw-r--r--meta/recipes-devtools/python/python3-ply_3.11.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-ply_3.11.bb b/meta/recipes-devtools/python/python3-ply_3.11.bb
new file mode 100644
index 0000000000..a05bd6702d
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-ply_3.11.bb
@@ -0,0 +1,18 @@
1SUMMARY = "Python Lex and Yacc"
2DESCRIPTION = "Python ply: PLY is yet another implementation of lex and yacc for Python"
3HOMEPAGE = "https://pypi.python.org/pypi/ply"
4SECTION = "devel/python"
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://README.md;beginline=5;endline=32;md5=f5ee5c355c0e6719c787a71b8f0fa96c"
7
8SRC_URI[md5sum] = "6465f602e656455affcd7c5734c638f8"
9SRC_URI[sha256sum] = "00c7c1aaa88358b9c765b6d3000c6eec0ba42abca5351b095321aef446081da3"
10
11inherit pypi setuptools3
12
13RDEPENDS:${PN}:class-target += "\
14 python3-netclient \
15 python3-shell \
16"
17
18BBCLASSEXTEND = "native nativesdk"