summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pluggy_1.5.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-pluggy_1.5.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pluggy_1.5.0.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pluggy_1.5.0.bb b/meta/recipes-devtools/python/python3-pluggy_1.5.0.bb
new file mode 100644
index 0000000000..9822cd59f3
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pluggy_1.5.0.bb
@@ -0,0 +1,29 @@
1SUMMARY = "Plugin and hook calling mechanisms for python"
2HOMEPAGE = "https://github.com/pytest-dev/pluggy"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=1c8206d16fd5cc02fa9b0bb98955e5c2"
5
6SRC_URI[sha256sum] = "2cffa88e94fdc978c4c574f15f9e59b7f4201d439195c3715ca9e2486f1d0cf1"
7
8DEPENDS += "python3-setuptools-scm-native"
9RDEPENDS:${PN} += "python3-importlib-metadata \
10 python3-more-itertools \
11"
12
13inherit pypi ptest python_setuptools_build_meta
14
15SRC_URI += " \
16 file://run-ptest \
17"
18
19RDEPENDS:${PN}-ptest += " \
20 python3-pytest \
21 python3-unittest-automake-output \
22"
23
24do_install_ptest() {
25 install -d ${D}${PTEST_PATH}/testing
26 cp -rf ${S}/testing/* ${D}${PTEST_PATH}/testing/
27}
28
29BBCLASSEXTEND = "native nativesdk"