summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pip_20.0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-pip_20.0.2.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pip_20.0.2.bb33
1 files changed, 0 insertions, 33 deletions
diff --git a/meta/recipes-devtools/python/python3-pip_20.0.2.bb b/meta/recipes-devtools/python/python3-pip_20.0.2.bb
deleted file mode 100644
index 99eeea2edf..0000000000
--- a/meta/recipes-devtools/python/python3-pip_20.0.2.bb
+++ /dev/null
@@ -1,33 +0,0 @@
1SUMMARY = "The PyPA recommended tool for installing Python packages"
2HOMEPAGE = "https://pypi.org/project/pip"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8ba06d529c955048e5ddd7c45459eb2e"
6
7DEPENDS += "python3 python3-setuptools-native"
8
9SRC_URI += "file://0001-change-shebang-to-python3.patch"
10
11SRC_URI[md5sum] = "7d42ba49b809604f0df3d55df1c3fd86"
12SRC_URI[sha256sum] = "7db0c8ea4c7ea51c8049640e8e6e7fde949de672bfa4949920675563a5a6967f"
13
14inherit pypi distutils3
15
16do_install_append() {
17 # Install as pip3 and leave pip2 as default
18 rm ${D}/${bindir}/pip
19}
20
21RDEPENDS_${PN} = "\
22 python3-compile \
23 python3-io \
24 python3-html \
25 python3-json \
26 python3-netserver \
27 python3-setuptools \
28 python3-unixadmin \
29 python3-xmlrpc \
30 python3-pickle \
31"
32
33BBCLASSEXTEND = "native nativesdk"