summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-packaging_24.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-packaging_24.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-packaging_24.1.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-packaging_24.1.bb b/meta/recipes-devtools/python/python3-packaging_24.1.bb
new file mode 100644
index 0000000000..20bcd55fba
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-packaging_24.1.bb
@@ -0,0 +1,37 @@
1SUMMARY = "Core utilities for Python packages"
2HOMEPAGE = "https://github.com/pypa/packaging"
3LICENSE = "Apache-2.0 | BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=faadaedca9251a90b205c9167578ce91"
5
6SRC_URI[sha256sum] = "026ed72c8ed3fcce5bf8950572258698927fd1dbda10a5e981cdf0ac37f4f002"
7
8SRC_URI += "file://run-ptest"
9
10inherit pypi python_flit_core ptest
11
12BBCLASSEXTEND = "native nativesdk"
13
14# Bootstrap the native build
15DEPENDS:remove:class-native = "python3-build-native"
16RDEPENDS:${PN} += "python3-profile"
17
18do_compile:class-native () {
19 python_flit_core_do_manual_build
20}
21
22do_install_ptest() {
23 cp -r ${S}/tests ${D}${PTEST_PATH}/
24 # We don't need this script which is used to build the binaries
25 rm -f ${D}${PTEST_PATH}/tests/manylinux/build.sh
26}
27
28RDEPENDS:${PN}-ptest = "\
29 python3-ctypes \
30 python3-pretend \
31 python3-pytest \
32 python3-unittest-automake-output \
33"
34
35# The ptest package contains prebuilt test binaries
36INSANE_SKIP:${PN} = "already-stripped"
37INSANE_SKIP:${PN}-ptest = "arch"