summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-numpy_1.26.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python3-numpy_1.26.4.bb')
-rw-r--r--meta/recipes-devtools/python/python3-numpy_1.26.4.bb64
1 files changed, 64 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-numpy_1.26.4.bb b/meta/recipes-devtools/python/python3-numpy_1.26.4.bb
new file mode 100644
index 0000000000..ccd08147af
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-numpy_1.26.4.bb
@@ -0,0 +1,64 @@
1SUMMARY = "A sophisticated Numeric Processing Package for Python"
2HOMEPAGE = "https://numpy.org/"
3DESCRIPTION = "NumPy is the fundamental package needed for scientific computing with Python."
4SECTION = "devel/python"
5LICENSE = "BSD-3-Clause & BSD-2-Clause & PSF-2.0 & Apache-2.0 & MIT"
6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a752eb20459cf74a9d84ee4825e8317c"
7
8SRCNAME = "numpy"
9
10SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/${SRCNAME}-${PV}.tar.gz \
11 file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \
12 file://0001-numpy-core-Define-RISCV-32-support.patch \
13 file://fix_reproducibility.patch \
14 file://run-ptest \
15 "
16SRC_URI[sha256sum] = "2a02aba9ed12e4ac4eb3ea9421c420301a0c6460d9830d74a9df87efa4912010"
17
18GITHUB_BASE_URI = "https://github.com/numpy/numpy/releases"
19UPSTREAM_CHECK_REGEX = "releases/tag/v?(?P<pver>\d+(\.\d+)+)$"
20
21DEPENDS += "python3-cython-native"
22
23inherit ptest setuptools3 github-releases
24
25S = "${WORKDIR}/numpy-${PV}"
26
27CLEANBROKEN = "1"
28
29do_compile:prepend() {
30 export NPY_DISABLE_SVML=1
31}
32
33FILES:${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a ${PYTHON_SITEPACKAGES_DIR}/numpy/random/lib/*.a"
34
35# install what is needed for numpy.test()
36RDEPENDS:${PN} = "python3-unittest \
37 python3-difflib \
38 python3-pprint \
39 python3-pickle \
40 python3-shell \
41 python3-doctest \
42 python3-datetime \
43 python3-misc \
44 python3-mmap \
45 python3-netclient \
46 python3-numbers \
47 python3-pydoc \
48 python3-pkgutil \
49 python3-email \
50 python3-compression \
51 python3-ctypes \
52 python3-threading \
53 python3-multiprocessing \
54 python3-json \
55"
56RDEPENDS:${PN}-ptest += "python3-pytest \
57 python3-hypothesis \
58 python3-sortedcontainers \
59 python3-resource \
60 python3-typing-extensions \
61 ldd \
62"
63
64BBCLASSEXTEND = "native nativesdk"